Bug 740753 - NM won't setup IBFT card
NM won't setup IBFT card
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 736893
  Show dependency treegraph
 
Reported: 2011-09-23 04:40 EDT by Ales Kozumplik
Modified: 2014-09-30 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.1.90-3.git20110927.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-29 19:30:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/syslog (119.04 KB, text/plain)
2011-09-23 04:40 EDT, Ales Kozumplik
no flags Details
Proposed patch to fix the iscsiadm patch (508 bytes, patch)
2011-09-26 04:24 EDT, Jirka Klimes
no flags Details | Diff

  None (edit)
Description Ales Kozumplik 2011-09-23 04:40:54 EDT
Created attachment 524562 [details]
/tmp/syslog

I can reproduce this in Anaconda in F16-Beta-TC2, an Intel IBFT card setup to use dhcp simply won't come up. This appears in the logs right after the failed attempt:

08:14:31,0 INFO NetworkManager: <info> (p3p1): now managed
08:14:31,0 INFO NetworkManager: <info> (p3p1): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2
]
08:14:31,0 INFO NetworkManager: <info> (p3p1): preparing device.
08:14:31,0 INFO NetworkManager: <info> (p3p1): deactivating device (reason: 2).
08:14:31,0 INFO NetworkManager: <info> (p3p1): device state change: unavailable -> disconnected (reason 'none') [20 30 0
]
08:14:39,699 DEBUG kernel:[   26.754027] p3p1: no IPv6 routers present
08:15:55,0 NOTICE NetworkManager:    ifcfg-rh: removed /etc/sysconfig/network-scripts/ifcfg-p3p1.
08:15:55,0 NOTICE NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-p3p1 ... 
08:15:55,0 NOTICE NetworkManager:    ifcfg-rh:     error: Failed to execute child process "/usr/sbin/iscsiadm" (No such 
file or directory)
08:15:55,0 NOTICE NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-p3p1 ... 
08:15:55,0 NOTICE NetworkManager:    ifcfg-rh:     error: Failed to execute child process "/usr/sbin/iscsiadm" (No such 
file or directory)
08:16:37,0 NOTICE NetworkManager:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-p3p1 ... 
08:16:37,0 NOTICE NetworkManager:    ifcfg-rh:     error: Failed to execute child process "/usr/sbin/iscsiadm" (No such 
file or directory)

Attaching the full log, note that Anaconda eventually establishes the connection through dhcp, but that is suboptimal (since it takes some clicking and some failed attempts).
Comment 1 Ales Kozumplik 2011-09-23 06:12:05 EDT
As far as I know, iscsiadm has always been at /sbin/iscsiadm.
Comment 2 Jirka Klimes 2011-09-26 04:21:59 EDT
We use sbindir as the path for iscsiadm.

After checking build log for the package,
http://kojipkgs.fedoraproject.org/packages/NetworkManager/0.8.3.998/1.fc14/data/logs/x86_64/build.log, it appears that sbin is /usr/sbin :

./configure --build=x86_64-redhat-linux-gnu --host=x86_64-redhat-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc .....

%_sbindir is defined as %{_exec_prefix}/sbin and 
%_exec_prefix           %{_prefix} and
%_prefix                /usr

So, we should probably hardcode "/sbin" instead of using sbindir.
What I'm confused about is how it could work so far. sbindir seems to have always been /usr/sbin.
Comment 3 Jirka Klimes 2011-09-26 04:24:49 EDT
Created attachment 524852 [details]
Proposed patch to fix the iscsiadm patch

Can we count on iscsiadm always being in /sbin?
Comment 4 Ales Kozumplik 2011-09-26 04:31:33 EDT
(In reply to comment #3)
> Created attachment 524852 [details]
> Proposed patch to fix the iscsiadm patch
> 
> Can we count on iscsiadm always being in /sbin?

I think so, it is needed very early in the system (dracut ramdisk) and those files are typically in /sbin.
Comment 5 Jirka Klimes 2011-09-26 10:00:12 EDT
Patch from comment #3 has been pushed upstream as f44959890b6eb9217470bc6809a0eb0f3f5efb9e
Comment 6 Fedora Update System 2011-09-27 10:11:58 EDT
NetworkManager-0.9.1.90-1.git20110927.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.1.90-1.git20110927.fc15
Comment 7 Fedora Update System 2011-09-27 10:16:28 EDT
NetworkManager-0.9.1.90-2.git20110927.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.1.90-2.git20110927.fc16
Comment 8 Fedora Update System 2011-09-27 13:33:37 EDT
Package NetworkManager-0.9.1.90-2.git20110927.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.1.90-2.git20110927.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.9.1.90-2.git20110927.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-09-27 15:24:09 EDT
NetworkManager-0.9.1.90-3.git20110927.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.1.90-3.git20110927.fc16
Comment 10 Fedora Update System 2011-09-29 19:30:07 EDT
NetworkManager-0.9.1.90-1.git20110927.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-09-30 15:30:25 EDT
NetworkManager-0.9.1.90-3.git20110927.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.