Bug 740793 - Assertion failure when forwarding message
Summary: Assertion failure when forwarding message
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 11:29 UTC by Tim Waugh
Modified: 2011-09-27 07:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-27 07:05:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 660224 None None None Never

Description Tim Waugh 2011-09-23 11:29:20 UTC
Description of problem:
When clicking the "Forward" button in a message window, the window just closes.  These messages appear in .xsession-errors:

(evolution:24838): evolution-shell-CRITICAL **: e_shell_backend_get_shell: assertion `E_IS_SHELL_BACKEND (shell_backend)' failed

(evolution:24838): evolution-mail-CRITICAL **: em_utils_forward_message: assertion `E_IS_SHELL (shell)' failed

Version-Release number of selected component (if applicable):
evolution-3.1.92-1.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Double click on a message to open its message window
2.Click Forward
  
Actual results:
Window closes, assertion failure in .xsession-errors, no further action.

Expected results:
Compose window for forwarding email.

Additional info:

Comment 1 Milan Crha 2011-09-27 07:05:28 UTC
Thanks for a bug report. I was unable to reproduce it for the first time, only after I set the browser window to close automatically when the shown message is forwarded/replied to.

I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=660224


Note You need to log in before you can comment on or make changes to this bug.