Bug 74081 - Nautilus can't unmount floppy of file system type "auto"
Nautilus can't unmount floppy of file system type "auto"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-15 03:06 EDT by alan
Modified: 2015-01-07 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 08:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alan 2002-09-15 03:06:02 EDT
Description of Problem:
If the floppy drive is defined in /etc/fstab as follows

    /dev/fd0      /mnt/floppy    auto    noauto,owner	0 0

(which is the default for the RedHat installation)
a DOS floppy that is mounted cannot be unmounted, because the
Nautilus floppy icon on the desktop has it in use.


Version-Release number of selected component (if applicable):


How Reproducible:
100%


Steps to Reproduce:
1.  Mount floppy with command
        mount /mnt/floppy
    Nautilus puts an icon of a floppy on the desktop
2.  Try to unmount the floppy with command
        umount /mnt/floppy
    You get the error message
        umount: /mnt/floppy: device is busy

Actual Results:
    A DOS floppy cannot be unmounted (without using a
    bizarre trick, described below)


Expected Results:
    You should be able to mount and unmount floppies
    as needed


Additional Information:
    If you drag the floppy icon into the trash, the 
    icon reappears on the desktop, but now the 
    device is no longer in use

    If the file system is described as "vfat" rather
    than "auto", this problem does not occur.
Comment 1 Alexander Larsson 2004-10-04 08:34:41 EDT
This is likely fixed in gnome 2.8.0. The whole way the device icons on
the desktop is handled has changed.

Note You need to log in before you can comment on or make changes to this bug.