Bug 740828 - Promotions Page Packages Infinite Scroll throws error
Summary: Promotions Page Packages Infinite Scroll throws error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Corey Welton
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-23 13:38 UTC by Eric Helms
Modified: 2013-08-16 18:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:57:49 UTC


Attachments (Terms of Use)

Description Eric Helms 2011-09-23 13:38:34 UTC
Description of problem:
Promotions page throws error when it reaches the end of infinite scroll list.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make sure a sync'd repository with 25+ packages exists.
2. Navigate to Promotions page.
3. Click through sliding tree to list of packages.
4. Scroll down till all packages are loaded.
  
Actual results:
Error message notification with: "You have a nil object when you didn't expect it! You might have expected an instance of Array. The error occurred while evaluating nil.empty?"

Expected results:
No errors.

Additional info:

Comment 1 Justin Sherrill 2011-10-04 19:34:46 UTC
should be fixed as part of:

691707fb4a41f594c35683a9cba29530bf84803a

Comment 2 Corey Welton 2011-10-25 04:42:39 UTC
QA Verified; tested with a repo of about 400 packages.  No error when scrolling to end.

Comment 5 Mike McCune 2013-08-16 18:18:10 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.