Bug 740835 - [RFE] Better handling of Prioritized/Priority fields in failover domain configuration
Summary: [RFE] Better handling of Prioritized/Priority fields in failover domain confi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2011-09-23 14:02 UTC by Radek Steiger
Modified: 2012-06-20 12:17 UTC (History)
2 users (show)

Fixed In Version: luci-0.26.0-9.el6
Doc Type: Enhancement
Doc Text:
Cause: Users could tick/untick checkboxes and enter values into text fields whose values were ignored because due to other settings being disabled while creating and editing failover domains. Consequence: Users were confused. Information they entered was thrown away and it wasn't clear why. Change: Checkboxes and text fields that were ignored are now disabled when their values will be ignored and re-enabled when their values are used. Result: Users can no longer enter information into form fields when that information will simply be ignored.
Clone Of:
Environment:
Last Closed: 2012-06-20 12:17:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0766 normal SHIPPED_LIVE luci bug fix and enhancement update 2012-06-19 19:30:16 UTC

Description Radek Steiger 2011-09-23 14:02:58 UTC
[ This RFE came out of Bug 705111 ]

Description of problem:

In Failover Domain configuration in Luci, Priority fields are never passed
without Prioritized flag being set.

This may result in a state where after Prioritized flag is removed, the Priority configuration remains stuck in and cannot be either removed or changed.

Possibly the best behavior would be removing all Priority flags when
Prioritized is being unset, and making the proper fields greyed out if we want
to have it polished for best user experience.


Version-Release number of selected component (if applicable):
luci-0.23.0-29.el6


How reproducible:
Always


Steps to Reproduce:
1. Create a failover domain with Prioritized flag set and Priority values set for all nodes
2. Remove the Prioritized flag without touching the Priority fields and submit
  

Actual results:
- all Priority values remain in place in both the form and cluster.conf
- changing or clearing the Priority fields makes absolutely no effect


Expected results:
- Priority values should be removed from both the form and cluster.conf

Comment 2 Lon Hohberger 2011-11-21 14:39:16 UTC
Note: rgmanager ignores priority values if a failover domain is not prioritized.

Comment 4 Radek Steiger 2011-12-06 11:53:02 UTC
Testable byboth visually checking the GUI and the generated cluster.conf file. Acking QA.

Comment 8 Lon Hohberger 2012-03-05 17:04:58 UTC
Is this an internal state change or have the screens changed?

Comment 9 Ryan McCabe 2012-03-06 17:00:49 UTC
The only visual change is that some fields are now slightly grayed out because they've been disabled and cannot accept user input in some states. The rest of the changes affect the interactions between the elements that cause particular inputs to be either enabled or disabled.

Comment 14 Ryan McCabe 2012-04-12 03:45:34 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Users could tick/untick checkboxes and enter values into text fields whose values were ignored because due to other settings being disabled while creating and editing failover domains.

Consequence: Users were confused. Information they entered was thrown away and it wasn't clear why.

Change: Checkboxes and text fields that were ignored are now disabled when their values will be ignored and re-enabled when their values are used.

Result: Users can no longer enter information into form fields when that information will simply be ignored.

Comment 16 errata-xmlrpc 2012-06-20 12:17:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0766.html


Note You need to log in before you can comment on or make changes to this bug.