Bug 740842 - TCK test sessionTtests is failing
Summary: TCK test sessionTtests is failing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-jca
Version: 2.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Weston M. Price
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 14:10 UTC by Jiri Pechanec
Modified: 2016-02-22 00:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 12:36:52 UTC


Attachments (Terms of Use)
TCK results (6.01 KB, application/x-gzip)
2011-09-23 14:10 UTC, Jiri Pechanec
no flags Details
TCK application (51.43 KB, application/x-gzip)
2011-09-23 14:11 UTC, Jiri Pechanec
no flags Details

Description Jiri Pechanec 2011-09-23 14:10:33 UTC
Created attachment 524624 [details]
TCK results

TCK test sessionTtests is failing during TCK execution.

There is no information in EAP server.log. The test result is
09-23-2011 07:07:20:  ERROR: java.lang.Exception: Null message received!
	at com.sun.ts.tests.jms.ee.ejb.sessionTtests.Client.simpleSendReceiveT(Client.java:157)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at com.sun.ts.lib.harness.EETest.run(EETest.java:495)
	at com.sun.ts.lib.harness.EETest.getPropsReady(EETest.java:392)
	at com.sun.ts.lib.harness.EETest.run(EETest.java:252)
	at com.sun.ts.lib.harness.EETest.run(EETest.java:204)
	at com.sun.ts.tests.jms.ee.ejb.sessionTtests.Client.main(Client.java:54)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.jboss.ejb3.client.ClientContainer.invokeMain(ClientContainer.java:269)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.jboss.ejb3.client.ClientLauncher.launch(ClientLauncher.java:301)
	at org.jboss.ejb3.client.ClientLauncher.launch(ClientLauncher.java:174)
	at org.jboss.ejb3.client.ClientLauncher.launch(ClientLauncher.java:138)
	at org.jboss.client.AppClientMain.main(Ap

The error is present if and only if the TCK is executed as the whole. I am not able to reproduce it when I execute only this single test.

This also makes logging on broker impractical so I cannot provide those data.

Comment 1 Jiri Pechanec 2011-09-23 14:11:13 UTC
Created attachment 524625 [details]
TCK application

Comment 2 Weston M. Price 2011-10-18 14:26:54 UTC
Being that this failure only occurs at the end of a full TCK run, I am loathe to keep this as an outstanding issue for this release being that a single test run completes successfully. As a result, I am moving this out for a later date.

Comment 3 Weston M. Price 2013-03-12 12:36:52 UTC
This is an old bug and falls under our rubric of TCK edge failures. As a result, I am going to close it. More specifically, this one only fails at the very end of a TCK run and appeared to be transient.


Note You need to log in before you can comment on or make changes to this bug.