Bug 740874 - Subscriptions show up as available in RHSM before product has been promoted out of Locker
Summary: Subscriptions show up as available in RHSM before product has been promoted o...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Bryan Kearney
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-23 15:39 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:57:53 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-09-23 15:39:22 UTC
Description of problem:


Version-Release number of selected component (if applicable):
 0.1.83-1.git.43.0db4170.fc14

How reproducible:


Steps to Reproduce:
1.  Create a custom provider, product and repo.
2.  Create an environment in ACME_Corporation (if not one there already)
3.  Register to katello with RHSM as admin/admin/ACME_Corporation/$YOUR_ENV
4.  subscription-manager list --available
  
Actual results:
Your product shows up

Expected results:
Your product does not show up until it's been promoted into your environment

Additional info:
You can actually subscribe to the product also, no repos are created.

Comment 3 Og Maciel 2012-02-24 19:48:43 UTC
As per https://bugzilla.redhat.com/show_bug.cgi?id=797242, subscription-manager behaves correctly.


# yum info subscription-manager
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
Seattle_RHN_CFTools                                      | 2.3 kB     00:00     
Seattle_RHN_RHEL_6.2                                     | 3.7 kB     00:00     
Seattle_RHN_RHEL_6Server                                 | 3.4 kB     00:00     
Installed Packages
Name        : subscription-manager
Arch        : x86_64
Version     : 0.96.17.2
Release     : 1.el6
Size        : 1.6 M
Repo        : installed
From repo   : /subscription-manager-0.96.17.2-1.el6.x86_64
Summary     : Tools and libraries for subscription and repository management
URL         : https://engineering.redhat.com/trac/subscription-manager
License     : GPLv2
Description : The Subscription Manager package provides programs and libraries
            : to allow users to manage subscriptions and yum repositories from
            : the Red Hat entitlement platform.

Comment 5 Mike McCune 2013-08-16 18:20:28 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.