Bug 74089 - libpspell has bogus dependences that explicitely include -lc
libpspell has bogus dependences that explicitely include -lc
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: pspell (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Eido Inoue
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-15 14:34 EDT by Pawel Salek
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 15:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2002-09-15 14:34:26 EDT
libpspell has bogus dependences that explicitely include -lc:
check out /usr/lib/libpspell.la, particularly dependency_libs. The list
includes: -L/usr/src/build/141109-i386/BUILD/pspell-.12.2/modules/.libs 
-L/usr/lib/gcc-lib/i386-redhat-linux/3.2/../../.. 

What is more important, it also includes explicitely -lc that makes it very
difficult - if not impossible - to link a threaded program.

How reproducible:
Always

Steps to Reproduce:
1. Just list the file.  or try linking a test threaded program that does fork
against this library.
	

Actual Results:  Described above.

Expected Results:  The linking order will become incorrect because libc will be
linked before libpthread, which will cause that the for example fork() function
will misteriously hang (becuse it will be taken from libc instead of libpthread).
Comment 1 Eido Inoue 2003-02-19 15:59:06 EST
aspell will be revamped in the next release
Comment 2 Pawel Salek 2003-02-19 16:13:57 EST
Any chance of distributing, say, aspell-0.50.x?

Note You need to log in before you can comment on or make changes to this bug.