Bug 740890 - Laptop goes in emergency thermal shutdown since switch to F16
Summary: Laptop goes in emergency thermal shutdown since switch to F16
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Garrett
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 16:27 UTC by Simo Sorce
Modified: 2013-07-18 13:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-13 18:59:37 UTC


Attachments (Terms of Use)

Description Simo Sorce 2011-09-23 16:27:14 UTC
Description of problem:
In F15 I never had issues, but since switching to F16 I have the laptop regularly overheating and going in thermal shutdown.

Lapto is a Thinkpad T500 with Intel gm45 gpu.

How reproducible:
Just let the laptop compile (use 100% of 1 of the 2 cores) for a few minutes.

I used a script to switch from ondemand to powersave(forces 800Mhz) when cpu temp as read from /proc/acpi/ibm/thermal reached above 89 and switched back to ondemand once temp was again below 60. Certainly not optimal but it let my machine never go in thermal shutdown.

Than I tried to set echo 90000 >/sys/class/thermal/thermal_zone0/passive

I stopped my script and started a busy loop to let the cpu go to 100% use.
Temperature quickly reached and surpassed 90 degrees, and setteled between 92/93 degrees for 5-10 minutes and then the acpi signaled again criutical was reached and machine shutdown.

I will try to set a lower value in passive, but it seem bad that the kernel does not throttle more aggressively when the threshold is reached and even surpassed.


If you need any test let me know, I still have around my old HDD with the F15 install.

Comment 1 Maxime Ménard-Leroux 2011-11-27 15:44:15 UTC
I have the same issue with my Thinkpad X200s.

Since I installed FC16, I started having thermal issues (fan not spinning, temperature often going up to 93 degrees Celcius and thermal shutdowns). Sometimes, the fan would rev up to max RPM for 30-45 seconds out of the blue and then suddenly stop for good until poweroff.

Since the last kernel update (3.1.2-1.fc16.x86_64), the fan started working again when my laptop just cleanly booted. But is still not spinning after resuming from suspend.

Comment 2 Nathan Kinder 2012-08-31 02:44:10 UTC
I realize that this bug is getting to be a bit old, but I've been having the same issue with my T500 running F16.  This laptop was fine with F15 and prior Fedora releases.  I primarily encounter thermal shutdown when running a VM to do compiling, or even just doing a yum update while running a single VM.

I can certainly provide any info that could help to track this problem down, but I think I'm going to have to do something similar to Simo to prevent my machine from shutting down while I'm in the middle of intensive tasks.

Comment 3 Dave Jones 2012-10-23 15:39:59 UTC
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).

Comment 4 Simo Sorce 2012-10-23 16:32:50 UTC
Hi Dave,
unfortunately I do not have the T500 anymore, so I can't test.

Comment 5 Fedora End Of Life 2013-01-16 15:52:19 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Fedora End Of Life 2013-02-13 18:59:41 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 7 cblanks@redhat.com 2013-07-18 13:25:03 UTC
Can I get a reopen on this bug?  I have reproduced this same issue on a T500 on Fedora 19.


Note You need to log in before you can comment on or make changes to this bug.