This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 740896 - Missing privilege separation directory: /var/empty/sshd - f16
Missing privilege separation directory: /var/empty/sshd - f16
Status: CLOSED DUPLICATE of bug 725137
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan F. Chadima
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 13:19 EDT by Nicolas Chauvet (kwizart)
Modified: 2011-09-26 05:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-26 05:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Chauvet (kwizart) 2011-09-23 13:19:56 EDT
Description of problem:
On F16, systemd report the sshd.service as failing.
When running the binary manually with:
/usr/sbin/sshd -D
The error is output is 
Missing privilege separation directory: /var/empty/sshd

Version-Release number of selected component (if applicable):
openssh-5.8p2-16.fc16.1

How reproducible:
always

Steps to Reproduce:
1. Try to start the sshd.service with systemctl
  
Actual results:
the service is failing

Expected results:
the service should work.

Additional info:
Creating the /var/empty/sshd directory allow the daemon to run.
Comment 1 Tomas Mraz 2011-09-26 05:59:31 EDT
Note that the package itself is OK. The problem is you had a broken openssh package installed before and you've upgraded from it. As the manual workaround is simple and the problem existed only in pre-alpha packages AFAIK I think it is fine to not introduce any automatic kludges/workarounds into the package.

*** This bug has been marked as a duplicate of bug 725137 ***

Note You need to log in before you can comment on or make changes to this bug.