Bug 740897 - pl fails to build for secondary arch ARM
pl fails to build for secondary arch ARM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On: 449456 740762
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 13:25 EDT by D. Marlin
Modified: 2016-05-11 18:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: pl-6.0.2-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 22:21:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Tool for getting java paths (2.59 KB, text/plain)
2011-09-27 09:26 EDT, Petr Pisar
no flags Details

  None (edit)
Description D. Marlin 2011-09-23 13:25:17 EDT
Description of problem:

The pl package fails to build for secondary arch ARM.

I see the following errors:

../swipl-ld.sh -shared -o libjpl.so src/c/jpl.o \
  -L/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.arm/jre/lib/arm/server \
  -L/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.arm/jre/lib/arm \
    -ljava -lverify -ljvm
/usr/bin/ld: cannot find -ljava
/usr/bin/ld: cannot find -lverify
/usr/bin/ld: cannot find -ljvm

The reason is that the installed Java path is:
  /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/arm

As a workaround, I modified the spec file to set JAVA_HOME and JAVA_LIB similar to sparcv9.  This allows the build to complete.

  +%ifarch %{arm}
  +export JAVA_HOME=/usr/lib/jvm/java-%{jdkvershort}-openjdk-%{jdkverlong}
  +export JAVA_LIB=$JAVA_HOME/jre/lib/arm
  +%else

Version-Release number of selected component (if applicable):

  pl-5.10.2-5
  java-1.6.0-openjdk-1.6.0.0

How reproducible:

  Always

Steps to Reproduce:
1.  need to use an ARM builder
2.  sample build log available at:
    http://arm-temp.ausil.us/pub/fedora-arm/stage4/pl-5.10.2-5.fc15/build.log

Actual results:

  fails to build successfully.

Expected results:

  build completes successfully.

Additional info:

This is part of the bootstrap effort for F15 for ARMv7.  Some of the packages, including java-1.6.0-openjdk are not yet built in koji.
Comment 1 Petr Pisar 2011-09-26 04:44:30 EDT
An ARM specific hack has been committed into F15 (pl-5.10.2-6.fc15) and higher.

Proper solution will be implemented after finding reliable way how to obtain JDK library path and JAVA_HOME directory.

JAVA_HOME can be set to /etc/alternatives/jre, JAVA_LIB can be constructed from System.out.println(System.getProperty("java.library.path")) string.

Unfortunately the java.library.path value is broken in java-1.7.0-openjdk now.
Comment 2 Petr Pisar 2011-09-27 09:26:06 EDT
Created attachment 525131 [details]
Tool for getting java paths

This is a tool to get linker path and JRE home directory for current JRE.
Comment 3 Petr Pisar 2011-09-30 05:06:28 EDT
The tool has been bundled to pl-5.10.5-4.fc17. Java SIG asked to integration into JDK.

Proper building pl verified on x86_64, i686, ppc, and ppc64. Sparc koji is unresponsive, ARM koji does not contain openjdk-1.6 yet. Feel free to check this release on those architectures.

Please not we cannot allow openjdk-1.7 because of bug #740762.
Comment 4 Fedora Update System 2012-03-22 08:47:01 EDT
pl-6.0.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pl-6.0.2-3.fc17
Comment 5 Fedora Update System 2012-03-22 20:42:39 EDT
Package pl-6.0.2-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pl-6.0.2-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4499/pl-6.0.2-3.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-11 22:21:05 EDT
pl-6.0.2-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.