Bug 74092 - kernel oops when identd
kernel oops when identd
Status: CLOSED DUPLICATE of bug 73733
Product: Red Hat Linux
Classification: Retired
Component: pidentd (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-15 16:20 EDT by Ed Kasky
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-17 13:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Kasky 2002-09-15 16:20:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Running identd causes kernel oops and the process dies.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load identd
2. Wait from 10 to 30 minutes
3.  Kernel Oops
 I get the same results with both 2.4.7-10 and 2.4.9-34	that I installed using 
up2date

Actual Results:  Sep  4 09:36:30 yoda2 identd: identd startup succeeded

Sep  4 10:00:01 yoda2 kernel:  <1>Unable to handle kernel NULL pointer 
dereference at virtual address 00000000
Sep  4 10:00:01 yoda2 kernel:  printing eip:
Sep  4 10:00:01 yoda2 kernel: e08e2b4f
Sep  4 10:00:01 yoda2 kernel: *pde = 00000000
Sep  4 10:00:01 yoda2 kernel: Oops: 0000
Sep  4 10:00:01 yoda2 kernel: CPU:    0
Sep  4 10:00:01 yoda2 kernel: EIP:    0010:
[tulip:__insmod_tulip_O/lib/modules/2.4.7-10/kernel/drivers/net/tu+-33969/96]
Sep  4 10:00:01 yoda2 kernel: EIP:    0010:[]
Sep  4 10:00:01 yoda2 kernel: EFLAGS: 00010246
Sep  4 10:00:01 yoda2 kernel: eax: bffffa40   ebx: 00000005   ecx: 00000000   
edx: 00000000
Sep  4 10:00:01 yoda2 kernel: esi: 00000000   edi: c874bf6c   ebp: c874bfbc   
esp: c874bf34
Sep  4 10:00:01 yoda2 kernel: ds: 0018	 es: 0018   ss: 0018
Sep  4 10:00:01 yoda2 kernel: Process identd (pid: 4359, stackpage=c874b000)
Sep  4 10:00:01 yoda2 kernel: Stack: 00660004 c874bf58 00000282 00000282 
00000001 00000094 ca0eade0 c6adc3a0 
Sep  4 10:00:01 yoda2 kernel:	     00000009 00001107 6e656469 00006474 
00000000 00000000 c874bf98 c5cf8000 
Sep  4 10:00:01 yoda2 kernel:	     dd3aad
20 dd3aad20 c874a000 00070000 
c874a000 00000000 c874bfc4 c0106369 
Sep  4 10:00:01 yoda2 kernel: Call Trace: [sys_sigreturn+185/240] 
[system_call+51/56] 
Sep  4 10:00:01 yoda2 kernel: Call Trace: [] [] 
Sep  4 10:00:01 yoda2 kernel: 
Sep  4 10:00:01 yoda2 kernel: Code: 66 83 3e 02 c7 45 b0 05 00 00 00 75 60 8d 
56 04 83 ec 08 0f 


Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-09-17 12:13:10 EDT
Not an identd issue.
Comment 2 Arjan van de Ven 2002-09-17 12:14:27 EDT
what modules are in use?
Comment 3 Ed Kasky 2002-09-17 13:22:56 EDT
I reported this on the recommendation of RH installation tech support.  I would 
be more than happy to supply you with any other information if you think it 
would help.

How do I get a list of other modules in use?
Comment 4 Arjan van de Ven 2002-09-17 13:28:38 EDT
type "lsmod"
Comment 5 Ed Kasky 2002-09-17 13:49:23 EDT
Without identd:

# /sbin/lsmod
Module                  Size  Used by    Tainted: P  
NVdriver              988288   0  (unused)
auditmodule            21912   1 
tulip                  39328   1 
usb-uhci               21668   0  (unused)
usbcore                51808   1  [usb-uhci]
ext3                   62624   3 
jbd                    41092   3  [ext3]
3w-xxxx                28448   4 
sd_mod                 11900   4 
scsi_mod               98584   2  [3w-xxxx sd_mod]
Comment 6 Arjan van de Ven 2002-09-17 13:51:36 EDT
ok wtf is 
auditmodule

if it's SNARE, please just remove it, it's chockful of bugs and doesn't actually
gain you any security. (anyone who looked at the code can circumvent logging
with 10 lines of C)

*** This bug has been marked as a duplicate of 73733 ***
Comment 7 Ed Kasky 2002-09-17 14:04:00 EDT
LOL!

I use wtf all the time myself!

I will rid the system of auditmodule and check 73733.

Note You need to log in before you can comment on or make changes to this bug.