Bug 740921 - When editing permissions for a role, existing verbs are not highlighted in box.
Summary: When editing permissions for a role, existing verbs are not highlighted in box.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-23 19:24 UTC by Corey Welton
Modified: 2013-08-16 17:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:58:01 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-09-23 19:24:37 UTC
Description of problem:
When trying to edit an existing role, the current verbs are not selected/highlighted in the combo box. User cannot tell for sure whether they are already selected or not.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a new Role, "Orgs Stuff"
2. Create a new Global Permission, "Create and Delete Org"
3. Click the "Edit Permissions" button, choose Permissions for: Organization and chose the associated verbs, "Create Organization" and "Delete Organization". Provide a name and click Done.
4. Observe the Verbs on the resulting view to assure these have been selected.
5. Click the "Edit Permissions" button once again.
6. Observe the Verb(s) combo box.  
  
Actual results:
The roles you selected previously are not highlighted

Expected results:
The roles that exist already should be selected.

Additional info:
If user makes no changes after step #6 and hits done, s/he will see that, indeed, no verbs have actually been modified. But when editing said permissions, it is not clear what already exists and what does not.

Comment 1 Eric Helms 2011-10-03 21:21:22 UTC
commit d1270c0ad46b0f93879bfa3d29474cdf068f8080

Both verbs and tags should show up as selected when editing a permission that had those items selected.

Comment 2 Corey Welton 2011-10-06 17:59:33 UTC
QA Verified

Comment 5 Mike McCune 2013-08-16 17:55:00 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.