Bug 740924 - Edit Role: Entire DIV container for the save/cancel button acts as cancel
Summary: Edit Role: Entire DIV container for the save/cancel button acts as cancel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Katello
Classification: Retired
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.0
Assignee: Shannon Hughes
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-23 19:41 UTC by Corey Welton
Modified: 2012-01-05 16:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-05 16:39:26 UTC


Attachments (Terms of Use)
screenshot (10.42 KB, image/png)
2011-09-23 19:44 UTC, Corey Welton
no flags Details

Description Corey Welton 2011-09-23 19:41:30 UTC
Description of problem:
When editing a role details, the div for the save and cancel buttons (for both Name and Description) highlight gray on mouseover; when clicking any area inside this div w/o clicking a button results in a cancelled submit.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  create a new role, "fibble"
2.  from the Roles View list, select "fibble"
3.  click the "Edit Roles" button"
4.  attempt to edit either the role name or description
5.  Noting the save/cancel buttons, hover over the div containing these buttons. Observe that div highlights gray.
6.  Click anywhere within this div

Actual results:
It appears the default action for clicking this div is "Cancel"

Expected results:
User should not be able to click the div - or at least not generate any action from it. Submit and Cancel via buttons should be the only actions.

Additional info:

Comment 1 Corey Welton 2011-09-23 19:44:06 UTC
Created attachment 524678 [details]
screenshot

Comment 2 Corey Welton 2011-09-23 23:05:23 UTC
Actually this seems to happen across some (but not all) other areas in the UI.  Another place it occurs is in custom provider, where it exists for Name and Description fields.

Comment 3 Jason E. Rist 2012-01-05 16:39:26 UTC
Clicking outside of an "editable" field is considered a cancel.  This is intended behavior.  If the consensus is that we don't want this to happen, then we need to probably discuss alternatives and implement them.


Note You need to log in before you can comment on or make changes to this bug.