Bug 740936 - Roles/Permissions: Add permission wizard seems to have an extra "Back" step.
Summary: Roles/Permissions: Add permission wizard seems to have an extra "Back" step.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-23 20:15 UTC by Corey Welton
Modified: 2013-08-16 18:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:58:12 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-09-23 20:15:19 UTC
Description of problem:
If user is going through the add permissions wizard after step #1 and clicks back on step #2, s/he seems to still be in the view for step #2. Clicking back again returns user to step #1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create new role
2.  Chose role from roles view
3.  Chose global permission and hit Add permission
4.  Chose a permission and click the "Next" button; note that the Name and Description fields appear
5. Click the back button.  Note that the same view exists
6. Click the back button again.  Note that we've returned back to the initial view  

Actual results:
 One step forward, two steps back :)

Expected results:
Proper navigation in wizard

Additional info:
* It seems that temporarily I was no longer able to no longer navigate any roles after doing this, but that might've been something else.
* Please do not get Paula Abdul stuck in your head while working on this bug.

Comment 1 Eric Helms 2011-09-29 15:08:48 UTC
commit 2932b3390e7ccf60478a5e950e9e8a846c6b08ff

This should sure up the workflow and remove the back button issue that was being seen.

Comment 2 Corey Welton 2011-10-06 18:08:10 UTC
QA Verified.

Comment 5 Mike McCune 2013-08-16 18:18:43 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.