Bug 740940 - SSM "remembers" previously joined configs
Summary: SSM "remembers" previously joined configs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2011-09-23 20:28 UTC by Brian
Modified: 2011-12-22 16:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-22 16:47:45 UTC


Attachments (Terms of Use)

Description Brian 2011-09-23 20:28:49 UTC
Description of problem:
System Set Manager will "remember" all config channels you've previously joined using SSM.

Version-Release number of selected component (if applicable):
At least 1.4 and 1.5

How reproducible:

Steps to Reproduce:
1. Start with 2 config channels and 2+ clients.  (In my tests all clients were already joined to a 3rd shared config channel.)
2. Select a subset of clients and use SSM -> Config Channel Subscriptions
3. Select only Config1 and go through normal confirmation process
4. Clear system set
5. Select a different subset and use SSM -> Config Channel Subscriptions
6. Note that Config1 isn't even offered!
7. Select only Config2 and go through normal confirmation process
8. Note this subset joined Config2, but also joined Config1
  
Actual results:
Selected clients will join all config channels you've previously joined through SSM

Expected results:
All available config channels will be offered in SSM.  Selected clients will join only the selected config channels.

Additional info:
This effect persists across sessions, and even different admin users.

Comment 1 Jan Pazdziora 2011-12-09 14:00:31 UTC
On Spacewalk 1.6 / nightly as of today, the reproducer is broken because the pages that should do the subscription suddenly don't have the list of systems, so it's not possible to finish the reproducer step 3. We need to investigate.

Comment 2 Tomas Lestach 2011-12-16 13:02:05 UTC
Borrowing the BZ for a time ...

Comment 3 Tomas Lestach 2011-12-16 14:13:44 UTC
The config channels were stored to a wrong rhnSet. :(

spacewalk.git: 047092925979e29b062c7136a2fc87a887b3799f

Comment 4 Milan Zázrivec 2011-12-22 16:47:45 UTC
Spacewalk 1.6 has been released.


Note You need to log in before you can comment on or make changes to this bug.