Bug 74096 - klpq displays scrambled information
klpq displays scrambled information
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdeutils (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-15 21:16 EDT by Geoff Russell
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 17:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is part of the klpq screen (9.41 KB, image/jpeg)
2002-09-15 21:18 EDT, Geoff Russell
no flags Details

  None (edit)
Description Geoff Russell 2002-09-15 21:16:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
klpq appears to be misparsing lpq output and the result is that
the program is unusable. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start klpq with some jobs on the print q
2.
3.
	

Actual Results:  Here is what I have in the jobs panel.
Rank   Owner               Job     Files                 Size
     0 geoff@loca              0   525      A  525 /tmp/..    0
     0 ies                     0                              0

Expected Results:  I should have a formatted list of printjobs.

Additional info:

This is vanilla RH7.3 out of the box with a KDE desktop. 

P.S. I've had to use command line lpq/lprm interface because I've
never had a working printer GUI in any
version of RH (6.0,6.1,6.2,7.0,7.1,7.3) that
I've used. This isn't a problem for me cause I very rarely
print anything, but I do voluntary
work for the RSPCA
who are using Linux and they aren't too keen on command lines!
Comment 1 Geoff Russell 2002-09-15 21:18:16 EDT
Created attachment 76224 [details]
This is part of the klpq screen
Comment 2 Tim Waugh 2002-09-16 04:36:08 EDT
Changing component.
Comment 3 Tim Waugh 2002-09-16 04:36:33 EDT
Reassigning.
Comment 4 Geoff Russell 2002-09-17 09:13:15 EDT
Here is some additional information.  klpq works on my friends mandrake
installation, so I checked is lpq. It gives very different output. So I'm guessing  
that when I did the KDE Workstation install in RH7.3 (with some additional
packages), that the wrong lpq was installed. i.e., klpq is incompatible
with LPRng's lpq. If kjobviewer worked I'd tell my users to use that, but
it doesn't - it takes about 20 seconds to respond to mouse clicks. My solution
has been to write my own print q manager and bolt it into my application. 

For users, control of the printer is critical, for RH7.3 to fail out of the
box on a vanilla install isn't good. You can't expect to replace MS as a desktop
system when such basic systems fail (this is criticism from someone who
refuses to work on Windows systems --- ever).
Comment 5 Ngo Than 2005-07-18 17:58:26 EDT
This bug should be fixed in FC4 current release. please reopen it if it still
appears. Thanks

Note You need to log in before you can comment on or make changes to this bug.