Bug 740960 - TypeError: 'float' object is not iterable
TypeError: 'float' object is not iterable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:b683c595e568319255ffe700391...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 17:50 EDT by Adam Williamson
Modified: 2011-09-23 18:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-23 18:42:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb-5tfiPm (406.49 KB, text/plain)
2011-09-23 17:50 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2011-09-23 17:50:06 EDT
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.1.0-0.rc6.git0.0.fc16.x86_64
product:        Fedora
reason:         TypeError: 'float' object is not iterable
time:           Fri Sep 23 14:48:39 2011
version:        16-Beta

anaconda-tb-5tfiPm: Text file, 416246 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.18 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/storage/partitioning.py", line 1752, in getDiskChunks
:    disk_free = [f for f in free if f.device.path == disk.path]
:  File "/tmp/updates/pyanaconda/storage/partitioning.py", line 1192, in allocatePartitions
:    temp_parts, freespace)
:  File "/tmp/updates/pyanaconda/storage/partitioning.py", line 1006, in doPartitioning
:    bootloader=bootloader)
:  File "/tmp/updates/pyanaconda/storage/partitioning.py", line 281, in doAutoPartition
:    doPartitioning(anaconda.storage, bootloader=anaconda.bootloader)
:  File "/tmp/updates/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/tmp/updates/pyanaconda/dispatch.py", line 241, in go_forward
:    self.dispatch()
:  File "/tmp/updates/pyanaconda/gui.py", line 1203, in nextClicked
:    self.anaconda.dispatch.go_forward()
:TypeError: 'float' object is not iterable
Comment 1 Adam Williamson 2011-09-23 17:50:10 EDT
Created attachment 524695 [details]
File: anaconda-tb-5tfiPm
Comment 2 Adam Williamson 2011-09-23 18:04:39 EDT
This is another crasher in updates-738964.7-nohammer.img , the fix for #738964. It's the same traceback tflink hit in comment #76, but by a different path.

The config I hit it with is:

VM with two VirtIO, image-backed disks, vda 15GB and vdb 10GB
vda contains an F15 install consisting of an ms-dos boot label, 500MB /boot partition, a 1GB swap partition, and a 5.5GB / partition; the other 8GB or so of space is free
vdb contains nothing at all, it's empty; disklabel is gpt, I believe

I hit the traceback by selecting 'Use Free Space', leaving 'Use LVM' checked, and putting vda (the 15GB drive) into the right-hand box ("Install Target Devices"). I leave vdb (the 10GB drive) in the left-hand box ("Data Storage Devices"). I hit next, and the error happens immediately.

Oddly, the trace looks like it wants to do stuff to vdb.

I confirmed that without the updates.img this crash does not occur, and if I choose 'review and modify partitioning layout', I can see anaconda does not put any partitions on vdb. It correctly places all its partitions into the free space on vda.
Comment 3 Adam Williamson 2011-09-23 18:42:08 EDT
so, this was caused by the hammer which should not have been in the nohammer image. confirmed 16.19 does not have this issue. closing.

Note You need to log in before you can comment on or make changes to this bug.