Bug 740970 - User creation: Password indicator should not show password strength of "Good" if password=username
Summary: User creation: Password indicator should not show password strength of "Good"...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-24 00:16 UTC by Corey Welton
Modified: 2013-08-16 18:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:58:21 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-09-24 00:16:11 UTC
Description of problem:
Just a nitpick. If user enters the same string for pass/confirm pass as they enter for username, it should be dinged right away, even if it is a good, "long" password

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Begin creating a new user.  enter the username "bobthebuilder"
2.  Enter "bobthebuilder" for pass/confirm pass as well.
3.  View password strength bar.
  
Actual results:
Strong password! 

Expected results:
Even if we allow it, we shouldn't be saying it's a strong password.

Additional info:

Comment 1 Justin Sherrill 2011-10-04 18:16:23 UTC
4b0c858b77aeb4f0ec888f14bdab3747abace23f

made it throw a warning and turn red if the password contains the username at all.

Comment 2 Corey Welton 2011-10-07 18:29:31 UTC
QA Verified.

Comment 5 Mike McCune 2013-08-16 18:09:23 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.