Bug 740990 - sane-backends-drivers- is providing libsane.so.1, this seems wrong
Summary: sane-backends-drivers- is providing libsane.so.1, this seems wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-24 08:38 UTC by Hans de Goede
Modified: 2012-12-20 16:16 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-20 16:16:35 UTC


Attachments (Terms of Use)

Description Hans de Goede 2011-09-24 08:38:09 UTC
Description of problem:

[hans@localhost ~]$ rpm -q --whatprovides 'libsane.so.1()(64bit)'
sane-backends-libs-1.0.22-4.fc16.x86_64
sane-backends-drivers-scanners-1.0.22-4.fc16.x86_64
sane-backends-drivers-cameras-1.0.22-4.fc16.x86_64

This, in combination with there not being any sane-backends-drivers-* for i686 in the x86_64 repo (will file a separate bug for that), and that repo thus still containing the old sane-backends-libs-gphoto2.i686, confuse yum into not wanting to update gtk3 for i686 (as that now depends on colord which in turn depends on
libsane.so.1 .

Moreover all 3 of them providing libsane.so.1 just seems wrong.

Comment 1 Michael Schwendt 2012-02-24 07:21:03 UTC
Confirmed. I've found a user, where two scanners don't work because of this as sane-backends-drivers-scanners apparently must be installed via "comps" and is not installed as dependency:

    $ rpm -qa \*sane\*
    libsane-hpaio-3.11.12-1.fc16.x86_64
->  sane-backends-drivers-cameras-1.0.22-8.fc16.x86_64
    xsane-0.998-4.fc16.x86_64
    sane-backends-libs-1.0.22-8.fc16.x86_64
    xsane-common-0.998-4.fc16.x86_64
    sane-backends-1.0.22-8.fc16.x86_64

http://lists.fedoraproject.org/pipermail/users/2012-February/414333.html

  # repoquery --whatprovides 'libsane.so.1()(64bit)'
  sane-backends-libs-0:1.0.22-8.fc16.x86_64
  sane-backends-drivers-scanners-0:1.0.22-5.fc16.x86_64
  sane-backends-libs-0:1.0.22-5.fc16.x86_64
  sane-backends-drivers-scanners-0:1.0.22-8.fc16.x86_64
  sane-backends-drivers-cameras-0:1.0.22-5.fc16.x86_64
  sane-backends-drivers-cameras-0:1.0.22-8.fc16.x86_64

  $ for l in /usr/lib64/sane/lib* ; do ( echo $l ; eu-readelf -d $l|grep SONAME ) ; done|grep libsane.so.1|wc -l
  249

Comment 2 Nils Philippsen 2012-03-01 17:11:51 UTC
(In reply to comment #0)
> Moreover all 3 of them providing libsane.so.1 just seems wrong.

This is an idiosyncrasy of the libtool ltmain.sh shipped in sane-backends and IIRC the reasoning is that apps can then links against the backend driver shared object (whyever). I'm thinking about doing away with that in Fedora, but it won't help with automatically getting the drivers installed (sorry Michael): they were split off to save space on live media, so requiring them now from the main package would be a bit pointless.

Comment 3 Fedora Update System 2012-09-01 12:31:15 UTC
sane-backends-1.0.23-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-1.fc17

Comment 4 Fedora Update System 2012-09-01 12:31:29 UTC
sane-backends-1.0.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-1.fc18

Comment 5 Fedora Update System 2012-09-01 12:31:39 UTC
sane-backends-1.0.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-1.fc16

Comment 6 Fedora Update System 2012-09-01 16:57:53 UTC
Package sane-backends-1.0.23-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sane-backends-1.0.23-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13120/sane-backends-1.0.23-1.fc18
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-09-04 15:16:22 UTC
sane-backends-1.0.23-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-2.fc16

Comment 8 Fedora Update System 2012-09-04 15:16:35 UTC
sane-backends-1.0.23-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-2.fc17

Comment 9 Fedora Update System 2012-09-04 15:16:48 UTC
sane-backends-1.0.23-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-2.fc18

Comment 10 Fedora Update System 2012-09-10 13:27:53 UTC
sane-backends-1.0.23-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-4.fc17

Comment 11 Fedora Update System 2012-09-10 13:28:10 UTC
sane-backends-1.0.23-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-4.fc16

Comment 12 Fedora Update System 2012-09-10 13:28:20 UTC
sane-backends-1.0.23-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sane-backends-1.0.23-4.fc18

Comment 13 Fedora Update System 2012-12-20 16:16:41 UTC
sane-backends-1.0.23-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.