Bug 741006 - Automated driver installation does not find gutenprint Canon iP4000 driver
Summary: Automated driver installation does not find gutenprint Canon iP4000 driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gutenprint
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: IEEE1284DeviceIDs
TreeView+ depends on / blocked
 
Reported: 2011-09-24 10:58 UTC by Oliver Henshaw
Modified: 2012-01-11 06:10 UTC (History)
2 users (show)

Fixed In Version: gutenprint-5.2.7-7.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-11 06:10:56 UTC


Attachments (Terms of Use)

Description Oliver Henshaw 2011-09-24 10:58:10 UTC
Description of problem:

I booted the F15 Desktop Livecd and plugged in a usb canon iP4000 driver. I received a notification that the system was searching for drivers and then that the ip4000 driver was "Missing". I then tried "Add"ing the printer using the "Printing" application which again failed to find the driver but let me manually select a driver from the database and steered me straight to the gutenprint iP4000 driver.

I then followed the testing procedure from the Fedora 14 printing test day - remove foomatic, foomatic-db-ppds, hpijs, gutenprint-cups (of which only gutenprint-cups was installed) and then tried again with the no better results, 


Finally, I checked the printer device id:

# python /usr/share/system-config-printer/check-device-ids.py

If you have not already done so, you may get more results
by temporarily disabling your firewall (or by allowing
incoming UDP packets on port 161).

Examining connected devices
Installing relevant drivers using session service
Fetching driver list
└── Canon iP4000 (usb): MFG:Canon;MDL:iP4000;CMD:BJL,BJRaster3,BSCCe;
    (No drivers)


Packages on livecd:
gutenprint-5.2.6-3.fc15.x86_64
system-config-printer-1.3.2-2.fc15.x86_64
cups-1:1.4.6-15.fc15.x86_64
cups-pk-helper-0.1.2-1.fc15.x86_64

Packages after update:
gutenprint-5.2.7-3.fc15.x86_64
system-config-printer-1.3.5-3.fc15.x86_64
cups-1.4.8-2.fc15.x86_64
cups-pk-helper-0.1.3-2.fc15.x86_64

Comment 1 Tim Waugh 2011-09-26 10:02:58 UTC
Thanks for the report.  The gutenprint-cups package has a driver (gutenprint.5.2://bjc-iP4000/simple) so this ID needs to be added to it.

Comment 2 Fedora Update System 2011-10-11 13:57:46 UTC
gutenprint-5.2.7-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gutenprint-5.2.7-7.fc16

Comment 3 Fedora Update System 2011-11-03 13:10:52 UTC
gutenprint-5.2.7-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gutenprint-5.2.7-7.fc15

Comment 4 Fedora Update System 2011-11-03 13:23:18 UTC
gutenprint-5.2.7-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gutenprint-5.2.7-7.fc14

Comment 5 Fedora Update System 2011-11-04 20:25:45 UTC
Package gutenprint-5.2.7-7.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gutenprint-5.2.7-7.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15367
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-11-05 01:21:03 UTC
gutenprint-5.2.7-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2012-01-11 06:10:56 UTC
gutenprint-5.2.7-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.