Bug 741023 - Scipy epel package fails dependency on NumPy, but NumPy is installed
Summary: Scipy epel package fails dependency on NumPy, but NumPy is installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: scipy
Version: el6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jef Spaleta
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-24 13:55 UTC by Ellert van Koperen
Modified: 2012-06-20 21:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 21:08:56 UTC


Attachments (Terms of Use)

Description Ellert van Koperen 2011-09-24 13:55:05 UTC
Description of problem:
Scipy epel package fails dependency on NumPy, but NumPy is installed

Version-Release number of selected component (if applicable):
latest

How reproducible:
try to install scipy with the add-software tool that has the epel-link.

Steps to Reproduce:
1. install numpy (nummeric-python) with the add-software tool that has the epel-link.
2. try to install scipy with the add-software tool that has the epel-link.
3.
  
Actual results:
dependency error

Expected results:
install

Additional info:

Comment 1 Jef Spaleta 2011-09-24 15:49:04 UTC
this just impacts el6?


I don't have an el6 install locally to test with.  I'll need some more info.


at the console  use yum and  yum install scipy and see if it provides and additional errors concerning the nature of the problem.


I'll try to do a scratch rebuild on the build system and see if it completes.

-jef

Comment 2 Ellert van Koperen 2011-09-24 19:05:10 UTC
Will do as soon as i have access to the rhel6 system again (monday).

Comment 3 Jef Spaleta 2011-09-24 21:31:55 UTC
Okay a scratch rebuild in the build system completed as expected.
http://koji.fedoraproject.org/koji/taskinfo?taskID=3374484


You can try to install the scipy packages that came out of that build as another test. But since that scratch build didn't fail i really need to see more information as to the problem you are seeing to give you any feedback.

Is this a rhel6 install or a centos6 install?
Does your system have numpy  and numpy-f2py packages installed?
If so give me the output of the following commands
rpm -q numpy
rpm -q numpy-f2py

If not
yum list numpy
yum list numpy-f2py


-jef

Comment 4 Ellert van Koperen 2011-09-26 08:11:55 UTC
Thank you for looking into this so quickly.

The system is RHEL6

rpm -q numpy -> not installed
rpm -q numpy-f2py -> not installed

yum list numpy -> not installed
yum list numpy-f2py -> not installed
yum list f2py -> not installed
How strange, in the add/remove software tool it is installed as installed. There it is called: Numeric 23.8-5.el6 (x86_64)

So if i do
yum install scipy -> it fails on dependencies to numpy and numpy-f2py
yum install numpy -> no package numpy available.
same for numpy-f2py of only f2py.

Thats where i start to glaze over... No idea really.

Comment 5 Orion Poplawski 2011-09-26 16:18:05 UTC
Numeric != numpy, that is python-numeric.

With RHEL6 you need to add the optional channel to get numpy-f2py:

rhn-channel --add rhel-x86_64-server-optional-6
yum install scipy

Comment 6 Jef Spaleta 2011-09-26 19:14:56 UTC
Oh there is an optional RHEL channel now? Fascinating. How is that positioned in terms of RHEL price points? Do all RHEL installs get access to that channel or is that a value-add offering?

I'm not sure EPEL is well structured to account for the channel splitting like that.

I might need to leave this bug open so I can mark duplicates against it.

I'm pretty sure this is going to be a common problem, but its not something I can fix in the scipy packaging. 

-jef

Comment 7 Orion Poplawski 2011-09-26 19:39:30 UTC
It's on the main EPEL wiki page:

https://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F

The optional channel is available to everyone as far as I know.


Note You need to log in before you can comment on or make changes to this bug.