Bug 741041 - kernel-devel-2.6.40.4-5.fc15.i686 panic when booting Asus Eee PC
Summary: kernel-devel-2.6.40.4-5.fc15.i686 panic when booting Asus Eee PC
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-24 15:50 UTC by Frank
Modified: 2011-09-26 14:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-25 14:31:03 UTC


Attachments (Terms of Use)
Screenshot of kernel panic (3.50 MB, image/jpeg)
2011-09-24 15:50 UTC, Frank
no flags Details

Description Frank 2011-09-24 15:50:14 UTC
Created attachment 524729 [details]
Screenshot of kernel panic

Description of problem:
After yum upgrade to kernel-2.6.40.4-5.fc15.i686, the machine does not boot up any more (see attachment). Kernel kernel-2.6.40.3-0.fc15.i686 still works fine.


Version-Release number of selected component (if applicable):
kernel-2.6.40.4-5.fc15.i686

How reproducible:
always

Steps to Reproduce:
1. boot
2. kernel panic
3.
  
Actual results:
panic

Expected results:
normal boot

Additional info:
using the old kernel-2.6.40.3-0 is a workaround

Comment 1 Josh Boyer 2011-09-24 17:35:59 UTC
Can you get more of the kernel boot logs?  It can't find the rootfs with that kernel, which might be due to the initramfs being corrupted or missing, or it might be something else.

To check the initramfs, make sure there is an initramfs file that matches the version number in /boot and is of similar size as the others.  Then make sure the bootloader config lists an initrd line with that initramfs file.

Comment 2 Frank 2011-09-25 10:51:52 UTC
initramfs wass mising for that kernel version. I removed the kernel and reinstalled it, and everything is fine now.
It seems that initramfs was not created during the first installation?

Comment 3 Josh Boyer 2011-09-25 14:31:03 UTC
Thanks for letting us know.  You'd need to look in your yum update logs and see if there was an error in producing the initramfs.

Comment 4 Frank 2011-09-26 14:37:31 UTC
It seems that "yum update" got interrupted *after* installing the new kernel, but *before* creating initramfs. yum-complete-transaction didn't recognized the incomplete kernel installation.


Note You need to log in before you can comment on or make changes to this bug.