Bug 74106 - /usr/bin/jar cannot extract mozilla's jar files
/usr/bin/jar cannot extract mozilla's jar files
Product: Red Hat Linux
Classification: Retired
Component: libgcj (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-09-16 05:11 EDT by Nakai
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.4.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-07 09:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nakai 2002-09-16 05:11:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.0.1) Gecko/20020830

Description of problem:
/usr/bin/jar fails to extract /usr/lib/mozilla-1.0.1/chrome/*.jar
which unzip can extract.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. jar xvf /usr/lib/mozilla-1.0.1/chrome/en-US.jar
2. It stops incorrectly.

Actual Results:  It fails to extract the correct jar files.

Expected Results:  It should extract like JDK's jar.

Additional info:

$ jar xvf en-US.jar 
   created: locale/
   created: locale/en-US/
   created: locale/en-US/global/
  inflated: locale/en-US/global/xpcom.properties
Error inflating file! (-3)
Comment 1 Tom Tromey 2002-12-18 16:49:12 EST
I tried the jar from gcc 3.3 (actually cvs trunk, but right now
those are the same) with the en-US.jar file from Mozilla 1.1.
It worked fine.  Based on this I think this problem is fixed on
the trunk.  FYI, HTH, etc.

Comment 2 Ville Skyttä 2003-01-27 15:19:34 EST
I've seen the "jar" from libgcj fail a number of times as well.  Would it be
possible to provide an update-alternatives symlink target for it?  That way it
would be easier to cleanly replace the libgcj one with a version that comes with
the user's JDK of choice.
Comment 3 Nakai 2004-09-09 04:43:40 EDT
Does this bug happen today? Anyone?
Comment 4 Tom Tromey 2004-09-09 10:56:10 EDT
There is still a problem with the jar on FC 2,
though it appears to be a different bug:

opsy. jar xvvf /usr/lib/mozilla-1.7.2/chrome/classic.jar Error! CRCs
do not match! Got e269f315, expected 50c4bef4

It also happens with a recent gcc head CVS jar.
Comment 5 Tom Tromey 2004-09-23 19:42:46 EDT
I checked in a fix for this.
It is here:


Jakub, if you want I can put this on the RH branch in gcc cvs.
Comment 6 Jakub Jelinek 2004-10-07 09:12:45 EDT
Should be fixed in gcc-3.4.2-5.

Note You need to log in before you can comment on or make changes to this bug.