Bug 741117 (b44_poll) - [abrt] kernel: WARNING: at kernel/softirq.c:159 _local_bh_enable_ip+0x3a/0x76(): TAINTED ---------W
Summary: [abrt] kernel: WARNING: at kernel/softirq.c:159 _local_bh_enable_ip+0x3a/0x76...
Keywords:
Status: CLOSED ERRATA
Alias: b44_poll
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c807ac36bde90d6c22e037ee062...
: 743354 749856 755074 756142 756375 756376 756379 757190 757447 757449 758090 765620 766517 768765 770049 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-25 15:50 UTC by e.chiesa73
Modified: 2012-02-06 16:56 UTC (History)
26 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-06 16:56:11 UTC


Attachments (Terms of Use)

Description e.chiesa73 2011-09-25 15:50:59 UTC
abrt version: 2.0.5.980
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.1.0-0.rc6.git0.0.fc16.i686 root=UUID=33616f6b-8871-463e-b1ad-71949fe8228a ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=it LANG=en_US.UTF-8
comment:        doing some random things, as watching a movie
kernel:         undefined
kernel_tainted: 512
kernel_tainted_long: Taint on warning.
reason:         WARNING: at kernel/softirq.c:159 _local_bh_enable_ip+0x3a/0x76()
reported_to:    kerneloops: URL=http://submit.kerneloops.org/submitoops.php
time:           Fri Sep 23 22:22:19 2011

backtrace:
:WARNING: at kernel/softirq.c:159 _local_bh_enable_ip+0x3a/0x76()
:Hardware name: Inspiron 9100                   
:Modules linked in: vfat fat ppdev parport_pc lp parport fuse fcoe libfcoe libfc scsi_transport_fc scsi_tgt 8021q garp stp llc ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables dell_laptop rfkill dcdbas microcode snd_intel8x0m snd_intel8x0 snd_ac97_codec ac97_bus snd_usb_audio snd_seq snd_hwdep snd_usbmidi_lib snd_rawmidi snd_seq_device snd_pcm joydev b44 iTCO_wdt iTCO_vendor_support ssb snd_timer snd soundcore snd_page_alloc mmc_core mii uinput uas usb_storage firewire_ohci firewire_core crc_itu_t yenta_socket video radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 2808, comm: applydeltarpm Not tainted 3.1.0-0.rc6.git0.0.fc16.i686 #1
:Call Trace:
: [<c08094e6>] ? printk+0x2d/0x2f
: [<c043cce5>] warn_slowpath_common+0x7c/0x91
: [<c0441cdf>] ? _local_bh_enable_ip+0x3a/0x76
: [<c0441cdf>] ? _local_bh_enable_ip+0x3a/0x76
: [<c043cd1c>] warn_slowpath_null+0x22/0x24
: [<c0441cdf>] _local_bh_enable_ip+0x3a/0x76
: [<c0441d28>] local_bh_enable_ip+0xd/0xf
: [<c0810fb1>] _raw_spin_unlock_bh+0x12/0x14
: [<f78c8858>] destroy_conntrack+0x91/0xcc [nf_conntrack]
: [<c076bdb8>] nf_conntrack_destroy+0x16/0x18
: [<c0746ff4>] skb_release_head_state+0x82/0xb7
: [<c0746dd8>] __kfree_skb+0x10/0x74
: [<c0746e83>] consume_skb+0x47/0x59
: [<f7d8c49f>] b44_poll+0x9a/0x3a6 [b44]
: [<c067b016>] ? scsi_decide_disposition+0xfe/0x192
: [<c0441e4e>] ? ftrace_define_fields_irq_handler_entry+0x71/0x71
: [<c074f2f6>] net_rx_action+0x95/0x18c
: [<c0441ef0>] __do_softirq+0xa2/0x17b
: [<c0441e4e>] ? ftrace_define_fields_irq_handler_entry+0x71/0x71
: <IRQ>  [<c044214c>] ? irq_exit+0x45/0x98
: [<c04042ba>] ? do_IRQ+0x7e/0x92
: [<c048ecb9>] ? rcu_irq_exit+0xd/0xf
: [<c044217b>] ? irq_exit+0x74/0x98
: [<c0418c8e>] ? smp_apic_timer_interrupt+0x69/0x76
: [<c0817170>] ? common_interrupt+0x30/0x38
: [<c0810000>] ? schedule_timeout_uninterruptible+0x12/0x1c

event_log:
:2011-09-25-17:43:10> Smolt profile successfully saved
:2011-09-25-17:50:43> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-09-25-17:50:49  Kernel oops report was uploaded

smolt_data:
:
:
:General
:=================================
:UUID: 1d0128e0-ff8f-4b27-a355-449b54c44c14
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: i686
:BogoMIPS: 5985.05
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Pentium(R) 4 CPU 3.00GHz
:CPU Stepping: 9
:CPU Family: 15
:CPU Model Num: 2
:Number of CPUs: 2
:CPU Speed: 3000
:System Memory: 1002
:System Swap: 564
:Vendor: Dell Inc.
:System: Inspiron 9100 
:Form factor: Portable
:Kernel: 3.1.0-0.rc6.git0.3.fc16.i686
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4172:44100:4136:345) pci, yenta_cardbus, PCI/CARDBUS, PCI4510 PC card Cardbus Controller
:(32902:9590:0:0) pci, None, BASE, 82865G/PE/P Processor to I/O Memory Interface
:(5348:17409:4136:33063) pci, b44, ETHERNET, BCM4401 100Base-T
:(32902:9435:4136:345) pci, ata_piix, STORAGE, 82801EB/ER (ICH5/ICH5R) IDE Controller
:(32902:9424:0:0) pci, None, PCI/ISA, 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge
:(32902:9430:5348:19812) pci, None, SIMPLE, 82801EB/ER (ICH5/ICH5R) AC'97 Modem Controller
:(32902:9429:4136:345) pci, None, MULTIMEDIA_AUDIO, 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller
:(4172:32809:4136:345) pci, firewire_ohci, FIREWIRE, PCI4510 IEEE-1394 Controller
:(32902:9294:0:0) pci, None, PCI/PCI, 82801 PCI Bridge
:(4098:20048:4136:380) pci, radeon, VIDEO, RV350 [Mobility Radeon 9600 M10]
:(32902:9428:4136:345) pci, uhci_hcd, USB, 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2
:(32902:9426:4136:345) pci, uhci_hcd, USB, 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1
:(32902:9584:4136:345) pci, agpgart-intel, HOST/PCI, 82865G/PE/P DRAM Controller/Host-Hub Interface
:(32902:9431:4136:345) pci, uhci_hcd, USB, 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3
:(32902:9438:4136:345) pci, uhci_hcd, USB, 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4
:(32902:9437:4136:345) pci, ehci_hcd, USB, 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller
:(32902:9585:0:0) pci, None, PCI/PCI, 82865G/PE/P PCI to AGP Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 3723268 1877034 1839215 950272 723808 723808
:

Comment 1 Piruthiviraj Natarajan 2011-10-04 06:29:43 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
after reboot this error happens every time in few seconds when i login to gnome-shell.

Comment 2 Ronald Canete 2011-10-04 10:54:03 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
After booting the machine and login... crash kernel report...

Comment 3 Ronald Canete 2011-10-04 12:03:23 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
After booting the machine and login... crash kernel report...

Comment 4 Piruthiviraj Natarajan 2011-10-05 07:24:05 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
this error occurs everytime i boot within few mins.

Comment 5 Josh Boyer 2011-10-24 19:56:04 UTC
*** Bug 743354 has been marked as a duplicate of this bug. ***

Comment 6 Laurent MAURIN 2011-11-05 12:39:26 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
nothing special

Comment 7 Laurent MAURIN 2011-11-06 08:32:35 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
nothing special

Comment 8 Laurent MAURIN 2011-11-06 17:50:31 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
nothing special

Comment 9 Chuck Ebbert 2011-11-18 20:35:54 UTC
*** Bug 755074 has been marked as a duplicate of this bug. ***

Comment 10 Chuck Ebbert 2011-11-18 20:36:12 UTC
*** Bug 749856 has been marked as a duplicate of this bug. ***

Comment 11 Laurent MAURIN 2011-11-19 20:42:18 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
opening a file with emacs over ssh on a remote client

Comment 12 Josh Boyer 2011-11-22 15:17:52 UTC
There's a potential patch for this here:

http://thread.gmane.org/gmane.linux.kernel/1218191/focus=1218541

I'll build a scratch kernel with that included later today.

Comment 13 Josh Boyer 2011-11-22 15:31:16 UTC
OK, the scratch build is here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3532333

when it completes, I would appreciate it if someone could test the kernel and see if the b44_poll backtrace still happens.

Comment 14 Josh Boyer 2011-11-22 20:06:34 UTC
*** Bug 756142 has been marked as a duplicate of this bug. ***

Comment 15 Josh Boyer 2011-11-23 12:36:29 UTC
*** Bug 756379 has been marked as a duplicate of this bug. ***

Comment 16 Josh Boyer 2011-11-23 12:37:01 UTC
*** Bug 756376 has been marked as a duplicate of this bug. ***

Comment 17 Josh Boyer 2011-11-23 12:37:16 UTC
*** Bug 756375 has been marked as a duplicate of this bug. ***

Comment 18 Josh Boyer 2011-11-28 12:50:25 UTC
*** Bug 757190 has been marked as a duplicate of this bug. ***

Comment 19 Josh Boyer 2011-11-28 14:20:48 UTC
*** Bug 757447 has been marked as a duplicate of this bug. ***

Comment 20 Josh Boyer 2011-11-28 14:21:01 UTC
*** Bug 757449 has been marked as a duplicate of this bug. ***

Comment 21 Josh Boyer 2011-11-29 15:21:09 UTC
*** Bug 758090 has been marked as a duplicate of this bug. ***

Comment 22 Chuck Ebbert 2011-12-09 00:25:04 UTC
*** Bug 765620 has been marked as a duplicate of this bug. ***

Comment 23 Old Uncle 2011-12-11 16:00:40 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Started installing LibreOffice via Yumex.

Comment 24 Josh Boyer 2011-12-12 12:28:29 UTC
*** Bug 766517 has been marked as a duplicate of this bug. ***

Comment 25 Josh Boyer 2011-12-19 13:54:39 UTC
*** Bug 768765 has been marked as a duplicate of this bug. ***

Comment 26 Saeed 2011-12-20 10:05:12 UTC
i dont know whay it happend?! :-/

it happend while i was surfing web via FF8 and downloading with UGet and WGet via terminal.


rating: (null)
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment 27 Josh Boyer 2011-12-20 14:34:40 UTC
I've backported a fix that went into the 3.2 kernel for this issue.  It should be included in the next f15/f16 kernel build.

Comment 28 Josh Boyer 2011-12-23 12:58:37 UTC
*** Bug 770049 has been marked as a duplicate of this bug. ***

Comment 29 Florian Fahr 2011-12-25 20:24:06 UTC
Network connection vanished while updating. Restarting caused kernel panic.

rating: (null)
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment 30 Florian Fahr 2011-12-25 20:59:07 UTC
Network connection vanished while updating. Restarting caused kernel panic.

Package: kernel
OS Release: Fedora release 16 (Verne)

Comment 31 Victor LIBON 2011-12-27 08:43:16 UTC
Package: kernel
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
The problem frequently occurs shortly after the start of Transmission (torrent software).

Comment 32 qwertz02 2012-01-10 14:04:20 UTC
every time on startup......boring

rating: (null)
Package: kernel
Architecture: i686
OS Release: Fedora release 16 (Verne)


Note You need to log in before you can comment on or make changes to this bug.