Bug 74112 - Login Manger impossible to cahnge
Summary: Login Manger impossible to cahnge
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: null
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-16 11:04 UTC by Olivier de Liocourt
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-16 21:02:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier de Liocourt 2002-09-16 11:04:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [fr] (X11; U; Linux 2.4.18-10 i686; Nav)

Description of problem:
changing /etc/sysconfig/desktop parameters to KDE or XDM doesn't work

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.field to complete DESKTOP="" with KDE, GNOME or XDM
2.init 3 && init 5
3.
	

Actual Results:  GNOME is always set. The problem is in the prefdm script. The
variable searched is DISPLAYMANAGER, and in /etc/sysconfig/desktop, the variable
is called DESKTOP

Expected Results:  changing to KDM or XDM

Additional info:

Comment 1 Mike A. Harris 2002-09-16 12:02:57 UTC
1) You're using the variables incorrectly.

2) This bug is filed against XFree86, and has nothing to do with the
   XFree86 package.

This is not a bug.  Please consult the appropriate Red Hat
documentation for proper usage of the /etc/sysconfig/desktop
file, and its variables.

Comment 2 Olivier de Liocourt 2002-09-16 15:26:01 UTC
no, sorry, I am not using variables incorectly.
put XDM in the DESKTOP="" field, do an init 3 && init 5, and you will see that it won't whange to 
XDM.
See th e/etc/X11/prefdm script, and you will see that the varibale is called DISPLAYMANAGER and 
not DESKTOP, so it can't work.
Change the variable name to DISPLAYMANAGER, and no problem fixed.

...but you are right, it doesn't concern XFree86 package, simply /etc/sysconfig/desktop is not owned 
by any package.

Comment 3 Miloslav Trmac 2002-09-16 21:02:28 UTC
$ rpm -qf /etc/X11/prefdm
initscripts-6.67-1

and you ARE using the variables incorrectly. Read the documentation
contained in the package.

Comment 4 Havoc Pennington 2002-09-17 04:32:27 UTC
To explain a bit more, there are two variables, DESKTOP and DISPLAYMANAGER,
which are orthogonal.


Note You need to log in before you can comment on or make changes to this bug.