Bug 741120 - Grub2 is unable to boot Fedora 16 on Lenovo Thinkpad X220 Tablet
Grub2 is unable to boot Fedora 16 on Lenovo Thinkpad X220 Tablet
Status: CLOSED DUPLICATE of bug 735733
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-25 12:33 EDT by Leonid Kanter
Modified: 2011-10-24 11:16 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 11:16:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2011-09-25 12:33:26 EDT
Description of problem:

Installed Fedora 16 from nightly build installation dvd, with "use entire disk" option. Laptop's bios doesn't recognize recognize fedora disk drive as a bootable disk. It tries in sequence to boot from hdd, network and then show boot menu. When I removed this drive and inserted into other laptop (Dell D620) - it booted OK.

Version-Release number of selected component (if applicable):

grub2-1.99-6.fc16.x86_64

How reproducible:


Steps to Reproduce:
1. Install F16 on X220 Tablet, install grub to /dev/sda (MBR)
2. Reboot
  
Actual results:

Laptop should boot to Fedora 16

Expected results:

It's unable to boot.
Comment 1 Thibault North 2011-10-03 15:20:15 EDT
Confirmed on F16 beta RC-4 for a X220.
Comment 2 D. Charles Pyle 2011-10-06 05:39:53 EDT
Confirmed also for F16 beta on a Dell Inspiron 560. I am left with a prompt that does nothing as follows:

GRUB_

I cannot type anything or run any commands (rescue or otherwise). This was with a fresh install of Fedora 16 Beta. I also tried to use yum to reinstall Grub2 and to remove it and replace it with grub to no avail. I was left with an unbootable system. Installation also warned about dependency problems between grub and grub2 during installation.

Initially, I tried to update my working Fedora 15 system running KDE 4.7.1 but this update to Fedora 16-Beta screwed up my system so badly that I couldn't even uninstall KDE, could not downgrade it, could not keep Gnome 3 running stably, and had literally thousands of dependency problems. After spending over 24 hours fixing over 3,000 dependency problems on the upgraded system, using several tools such as rpm, yum, rpmreaper, etc., no more could be fixed and I ended up finally giving up and doing the fresh installation of 16 beta. That is when I got the abovemost problem I mentioned.

When I had intially run the upgrade, I could not boot the system at all because the option to leave the original boot configuration intact failed to write the new kernel information to /boot/grub/grub.conf. I had to enter the information manually in a recovery shell just to get the system to boot.

Good thing I knew the risks of installing Beta software. :-)
Comment 3 Marcus Husar 2011-10-13 07:06:52 EDT
I can also confirm this problem for F16 beta on a Lenovo S205 (bios mode with msdos partitiontable, because the EFI is too buggy to use).

I am not able to boot from my internal harddisk, but can help out with a GRUB2 installed in the MBR of my usb flash drive.

The only thing I can see from GRUB2 is „GRUB Loading.“ (yes, only one dot). After two or three seconds the system reboots.

How can I debug this and help to fix these probems? I would be delighted to have no boot problems.

Many thanks
Marcus
Comment 4 Brian Lane 2011-10-18 09:21:51 EDT
Try the update image from comment 19 in bug 735733
Comment 5 Marko Myllynen 2011-10-18 10:02:18 EDT
(In reply to comment #4)
> Try the update image from comment 19 in bug 735733

I can confirm that with

  updates=http://dlehman.fedorapeople.org/updates-735733.0.img nogpt

Fedora 16 Beta now boots and works on Lenovo Thinkpad X220.

Thanks!
Comment 6 Adam Williamson 2011-10-24 11:16:45 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 735733 ***

Note You need to log in before you can comment on or make changes to this bug.