Bug 741157 - ibus-m17n: m17n "title" variable appears as a dormant button on the language panel
Summary: ibus-m17n: m17n "title" variable appears as a dormant button on the language ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-m17n
Version: 15
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 04:23 UTC by Harshula Jayasuriya
Modified: 2011-10-09 19:33 UTC (History)
4 users (show)

Fixed In Version: ibus-m17n-1.3.3-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-09 06:51:34 UTC


Attachments (Terms of Use)

Description Harshula Jayasuriya 2011-09-26 04:23:32 UTC
Description of problem:

The language panel's m17n "input-method" and "title" variables appear as buttons. Only the m17n "input-method" variable's button actually does anything. Do we really need both?

Version-Release number of selected component (if applicable):
* ibus-m17n 1.3.3

How reproducible:
* Always

Steps to Reproduce:
1. Set "Show language panel" to "When active" in IBus Preferences
2. Enable IBus
3. Move the cursor to the language panel and hover over the m17n "title" string.
  
Actual results:
* The m17n "title" string appears as a button

Expected results:
* The m17n "title" string should NOT appear as a button

Comment 1 Daiki Ueno 2011-09-26 09:16:50 UTC
The one looks like "title" is a changeable text used for some IMEs to display states.  I'm thinking of adding a config option to hide it for state-less IMEs.
Yes, it will be still displayed as a button not a text for state-full IMEs, but it is another issue and maybe not so annoying.

Comment 2 Fedora Update System 2011-09-29 05:01:54 UTC
ibus-m17n-1.3.3-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-m17n-1.3.3-5.fc16

Comment 3 Fedora Update System 2011-09-29 05:03:16 UTC
ibus-m17n-1.3.3-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-m17n-1.3.3-5.fc15

Comment 4 Daiki Ueno 2011-09-29 07:02:11 UTC
(In reply to comment #1)
> I'm thinking of adding a config option to hide it for state-less IMEs.

I ended up with not adding such a config option, but hiding the status prop if it is equal to IME title.

Comment 5 Fedora Update System 2011-09-29 17:13:08 UTC
Package ibus-m17n-1.3.3-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-m17n-1.3.3-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-m17n-1.3.3-5.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-10-09 06:51:34 UTC
ibus-m17n-1.3.3-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-10-09 19:33:28 UTC
ibus-m17n-1.3.3-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.