Bug 74117 - [PATCH] for linux_logo.h from kernel-source
[PATCH] for linux_logo.h from kernel-source
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
All Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-16 09:44 EDT by Felipe Alfaro Solana
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 20:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2002-09-16 09:44:38 EDT
Description of Problem:
-----------------------
Red Hat Linux kernel source includes a customized logo that shows up during boot
up on framebuffer-enabled kernels (i.e. VESA fb). The logo is defined in the
include file "include/linux/linux_logo.h".

In this header file, a comment instructs the user that, in order to be able to
use this customized Red Hat logo instead of the default one (the Linux Penguin),
the user has to edit the file "drivers/video/fbcon.c" file and change the
definitions of LOGO_H and LOGO_W.

The problem is that the comment reads:

   #define LOGO_H 800
   #define LOGO_W 60

This is wrong. The logo height is 60 pixels, and the logo width is 800 pixels,
so the comment should be fixed and swapped as:

   #define LOGO_H 60
   #define LOGO_W 800

Please, see the diff unified patch at the end of this report. Apply it to the
current kernel-source package (I generated the diff from 2.4.8-10) so it stays
consistent.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
kernel-source-2.4.8-10

How Reproducible:
-----------------
Always, since kernel-source-2.4.8-5 (AFAIK)

Steps to Reproduce:
-------------------
1. Install kernel-source-2.4.18-10 (for example)
2. Look at /usr/src/linux-2.4.18-10/include/linux/linux_logo.h
3. Read the comments at the beginning of the file

Actual Results:
---------------
LOGO_H is 800, as read in the comments section of linux_logo.h
LOGO_W is 60, as read in the comments section of linux_logo.h

Expected Results:
-----------------
LOGO_H should be 60, as read in the comments section of linux_logo.h
LOGO_W should be 800, as read in the comments section of linux_logo.h


Additional Information:
-----------------------	
A small unified diff patch to fix this:

--- linux_logo.h	2002-09-16 15:34:27.000000000 +0200
+++ linux_logo.h.orig	2002-09-16 15:34:18.000000000 +0200
@@ -11,8 +11,8 @@
  *
  *
  * Remember to modify drivers/video/fbcon.c:
- * Change "#define LOGO_H 80" to "#define LOGO_H 60"
- * Change "#define LOGO_W 80" to "#define LOGO_W 800"
+ * Change "#define LOGO_H 80" to "#define LOGO_H 800"
+ * Change "#define LOGO_W 80" to "#define LOGO_W 60"
  */
 
 #ifndef __HAVE_ARCH_LINUX_LOGO
Comment 1 Arjan van de Ven 2002-09-16 09:52:51 EDT
*blink*
That header is autogenerated, but yes the comment is wrong. However I seem to
not be able to find the cause of it being wrong on first sight; investigating
further
Comment 2 Arjan van de Ven 2002-09-16 09:58:48 EDT
ok found it; fixed for next build; thanks for the report
Comment 3 Felipe Alfaro Solana 2003-02-02 14:35:27 EST
Hmmm... It seems the beautiful Red Hat boot logo has been removed from the 
kernel as of kernel-source-2.4.20-2.30. Instead, I see the standard penguin 
boot logo... What a pity! I liked it so much. I still have at hand 
the "linux_logo.h" file containing the original Red Hat boot logo so I can 
manually patch the kernel and preserve it in new kernels.

Will the original 800x60 Red Hat boot logo (or an updated version) be included 
in new releases of the kernel-source RPM, or will the penguin boot logo stay 
forever?
Comment 4 Felipe Alfaro Solana 2004-09-28 20:05:34 EDT
This bug is not applicable anymore to current versions of the RedHat
kernel.

Note You need to log in before you can comment on or make changes to this bug.