Bug 741176 - ibus compose file needs a symbol tag for gnome-shell
Summary: ibus compose file needs a symbol tag for gnome-shell
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-sayura
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 727019
Blocks: 741189
TreeView+ depends on / blocked
 
Reported: 2011-09-26 07:19 UTC by Pravin Satpute
Modified: 2011-11-25 02:00 UTC (History)
6 users (show)

Fixed In Version: ibus-indic-table-1.3.1-14.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of: 727019
: 741189 (view as bug list)
Environment:
Last Closed: 2011-10-20 04:02:46 UTC


Attachments (Terms of Use)

Description Pravin Satpute 2011-09-26 07:19:09 UTC
+++ This bug was initially created as a clone of Bug #727019 +++

The latest ibus-gnome3 + gnome-shell can show a special symbol char on ibus
status icon by ibus engine.
The symbol can be defined in engine's /usr/share/ibus/component/*.xml .

Now ibus-anthy-1.2.6-3 has a symbol char and the similar fix is needed for
major ibus engines.

% grep symbol /usr/share/ibus/component/anthy.xml
   <symbol>&#x3042;</symbol>

The following patch is the example:
http://pkgs.fedoraproject.org/gitweb/?p=ibus-anthy.git;a=blob_plain;f=ibus-anthy-xx-icon-symbol.patch
http://pkgs.fedoraproject.org/gitweb/?p=ibus-hangul.git;a=blob_plain;f=ibus-hangul-xx-icon-symbol.patch

(Note: probably you don't need hotkeys tag since your engine would need Control
+ Space only for the trigger)

--- Additional comment from tagoh@redhat.com on 2011-09-08 04:25:44 EDT ---

Ping.

Any chance to get this prior to Beta?

--- Additional comment from psatpute@redhat.com on 2011-09-08 06:17:13 EDT ---

yes, will try to do before Beta.

--- Additional comment from psatpute@redhat.com on 2011-09-14 01:53:42 EDT ---

Fujiwara i gone through feature you have added it nice.
I feel icons are more informative than single characters, so i would like to continue with the icons, might be we can make it little bit smaller and matching with the gnome-shell theme.

--- Additional comment from tfujiwar@redhat.com on 2011-09-14 21:16:32 EDT ---

(In reply to comment #3)
> Fujiwara i gone through feature you have added it nice.
> I feel icons are more informative than single characters, so i would like to
> continue with the icons, might be we can make it little bit smaller and
> matching with the gnome-shell theme.

However I think the character icon is the policy of gnome-shell:
https://live.gnome.org/GnomeShell/Design/Guidelines/SystemStatus/InputLanguage

If you don't add '<symbol>' tag, the default is the two chars from the engine's language.
The problem is, if you use input method is 'tamil-99' and keymap is 'Tamil', both icon will be 'ta'.
If you think 'tamil-99' is keymap, probably the default language chars are ok.
But if it's input method in which you often need to disable the IM status, probably it's better to assign a multi-byte char.

For Fedora 16, gnome-shell-3.1.91-2.fc16, gjs-1.29.17-1.fc16 and ibus-gnome3-1.3.99.20110817-5.fc16 are required.
Also gnome-shell disables any extensions by default in Fedora 16 so you need to enable ibus-gnome3 by manual to set gsettings:
https://fedoraproject.org/wiki/QA:Testcase_ibus_gnome_shell
https://fedoraproject.org/wiki/I18N/InputMethods#GNOME-Shell

Regarding to the icon size, currently I'd think to fix to install ibus-gnome3 instead of using pygtk2 statusicon on gnome-shell.

Comment 1 Fedora Update System 2011-09-26 08:43:02 UTC
ibus-sayura-1.3.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-sayura-1.3.1-2.fc16

Comment 2 Fedora Update System 2011-09-26 08:44:13 UTC
ibus-sayura-1.3.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-sayura-1.3.1-2.fc15

Comment 3 Fedora Update System 2011-09-26 16:48:34 UTC
Package ibus-sayura-1.3.1-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-sayura-1.3.1-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-sayura-1.3.1-2.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-10-03 10:21:09 UTC
ibus-indic-table-1.3.1-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-7.fc16

Comment 5 Fedora Update System 2011-10-03 10:25:15 UTC
ibus-indic-table-1.3.1-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-7.fc15

Comment 6 Fedora Update System 2011-10-10 05:17:29 UTC
ibus-indic-table-1.3.1-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-8.fc15

Comment 7 Fedora Update System 2011-10-10 05:18:01 UTC
ibus-indic-table-1.3.1-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-8.fc16

Comment 8 Fedora Update System 2011-10-17 11:45:41 UTC
ibus-indic-table-1.3.1-10.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-10.fc15

Comment 9 Fedora Update System 2011-10-17 11:46:43 UTC
ibus-indic-table-1.3.1-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-10.fc16

Comment 10 Fedora Update System 2011-10-20 04:02:46 UTC
ibus-sayura-1.3.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-10-20 07:38:36 UTC
ibus-indic-table-1.3.1-14.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-14.fc15

Comment 12 Fedora Update System 2011-10-20 07:39:18 UTC
ibus-indic-table-1.3.1-14.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-indic-table-1.3.1-14.fc16

Comment 13 Fedora Update System 2011-10-20 09:53:25 UTC
ibus-sayura-1.3.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-10-25 03:46:33 UTC
ibus-indic-table-1.3.1-14.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-11-25 02:00:12 UTC
ibus-indic-table-1.3.1-14.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.