Bug 741190 - VDSM: /etc/logrotate.d/libvirtd contains bad data, causes e-mail flood from cron
Summary: VDSM: /etc/logrotate.d/libvirtd contains bad data, causes e-mail flood from cron
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.1
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: 6.2
Assignee: Dan Kenigsberg
QA Contact: Daniel Paikov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 08:04 UTC by Daniel Paikov
Modified: 2013-07-04 07:51 UTC (History)
10 users (show)

Fixed In Version: vdsm-4.9-107
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:28:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Daniel Paikov 2011-09-26 08:04:02 UTC
/etc/logrotate.d/libvirtd on some hosts contains the same section multiple times, which means that the output of "logrotate /etc/logrotate.d/libvirtd" looks like this:

[root@north-06 ~]# logrotate /etc/logrotate.d/libvirtd
error: /etc/logrotate.d/libvirtd:14 duplicate log entry for /var/log/libvirtd.log
error: found error in /var/log/libvirtd.log , skipping

This means that every time cron runs logrotate (every 15 minutes), it sends an e-mail to root with the error it receives from logrotate.

Contents of /etc/logrotate.d/libvirtd:

[root@north-06 ~]# cat /etc/logrotate.d/libvirtd
# vdsm
/var/log/libvirtd.log {
    rotate 100
    missingok
    copytruncate
    size 15M
    compress
    compresscmd /usr/bin/xz
    uncompresscmd /usr/bin/unxz
    compressext .xz
}
# end vdsm
# vdsm
/var/log/libvirtd.log {
    rotate 100
    missingok
    copytruncate
    size 15M
    compress
    compresscmd /usr/bin/xz
    uncompresscmd /usr/bin/unxz
    compressext .xz
}
# end vdsm
/var/log/libvirt/libvirtd.log {
        weekly
        missingok
        rotate 4
        compress
        delaycompress
        copytruncate
        minsize 100k
}

Comment 2 Daniel Veillard 2011-09-26 09:06:04 UTC
/etc/logrotate.d/libvirtd is a file owned by libvirt package:

[root@test ~]# rpm -qf /etc/logrotate.d/libvirtd
libvirt-0.9.4-12.el6.x86_64
[root@test ~]# rpm -V libvirt
.M.......    /var/cache/libvirt/qemu
[root@test ~]# cat /etc/logrotate.d/libvirtd
/var/log/libvirt/libvirtd.log {
        weekly
        missingok
        rotate 4
        compress
        delaycompress
        copytruncate
        minsize 100k
}
[root@test ~]# 

But as you can see its content contains only one entry and no comment about vdsm.
My guess is that the extra definitions are added by vdsm in some ways, and
the bug should be retargetted at this component,

Daniel

Comment 3 Dan Kenigsberg 2011-09-26 10:33:05 UTC
Did you find a reliable way to reproduce this condition?
Does removing vdsm and installing it solves the problem?

Comment 4 Daniel Paikov 2011-09-26 11:19:25 UTC
Didn't find a way to reproduce yet, but I have this issue on all my hosts.

yum remove vdsm / yum install vdsm makes /etc/logrotate.d/libvirtd go back to normal.

Comment 5 Dan Kenigsberg 2011-09-27 06:57:57 UTC
http://gerrit.usersys.redhat.com/971

Comment 7 Daniel Paikov 2011-10-09 13:02:47 UTC
How do we test this?

Comment 8 Dan Kenigsberg 2011-10-09 13:29:16 UTC
(In reply to comment #7)
> How do we test this?

try install/upgrade/uninstall ov vdsm and make sure that never ever do you get multiple "vdsm" stanzas in logrotate.d/libvirtd, and that no nagging email is sent due to vdsm installation.

Comment 9 Daniel Paikov 2011-10-09 13:37:06 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > How do we test this?
> 
> try install/upgrade/uninstall ov vdsm and make sure that never ever do you get
> multiple "vdsm" stanzas in logrotate.d/libvirtd, and that no nagging email is
> sent due to vdsm installation.

What about hosts that already have this problem? Does it fix it retroactively?

Comment 10 Dan Kenigsberg 2011-10-09 15:11:57 UTC
(In reply to comment #9)
> 
> What about hosts that already have this problem? Does it fix it retroactively?

it should.

Comment 11 Daniel Paikov 2011-10-12 11:15:01 UTC
Upgraded to 4.9-107, the file still has multiple instances of the same garbage. Moving back to ASSIGNED.

Comment 12 Dan Kenigsberg 2011-10-12 13:43:51 UTC
upgraded from what? did the garbage exist beforehence? would the secret
service vdsmd reconfigure
remove it?

Comment 13 Dan Kenigsberg 2011-10-15 20:37:48 UTC
Either way, it is a bit too late to handle these minor details. If vdsm does not add multiple stanzas, that's good enough for 3.0. I wish I could take back my comment 10.

Comment 14 Daniel Paikov 2011-10-16 08:37:04 UTC
Upgraded from 106 to 107.

service vdsmd reconfigure does help. The file now looks like this and logrotate doesn't have any output.

[root@orange-vdsf ~]# cat /etc/logrotate.d/libvirtd
# vdsm
/var/log/libvirtd.log {
    rotate 100
    missingok
    copytruncate
    size 15M
    compress
    compresscmd /usr/bin/xz
    uncompresscmd /usr/bin/unxz
    compressext .xz
}
# end vdsm
/var/log/libvirt/libvirtd.log {
        weekly
        missingok
        rotate 4
        compress
        delaycompress
        copytruncate
        minsize 100k
}

Comment 15 Daniel Paikov 2011-10-18 10:57:36 UTC
Checked on 4.9-108.

Comment 16 errata-xmlrpc 2011-12-06 07:28:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.