Bug 741195 - arping cannot choose em1 to default ethernet device
arping cannot choose em1 to default ethernet device
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iputils (Show other bugs)
6.2
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Jan Synacek
qe-baseos-daemons
: Patch
Depends On:
Blocks: 947775
  Show dependency treegraph
 
Reported: 2011-09-26 04:37 EDT by Liang Zheng
Modified: 2013-07-28 21:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 04:21:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
[Patch] Look for "eth" or "em" in /proc/self/net/dev (2.19 KB, patch)
2012-07-16 08:10 EDT, Jan Synacek
no flags Details | Diff

  None (edit)
Description Liang Zheng 2011-09-26 04:37:27 EDT
Description of problem:
When your  default ethernet device isnot eth0 ,it is em1 or p1p1,
arping cannot choose em1 to default ethernet device 

Version-Release number of selected component (if applicable):
iputils-20071127-16.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.arping 192.168.1.1

  
Actual results:
[root@dell-per715-01 ~]# ip route
10.16.40.0/21 dev em1  proto kernel  scope link  src 10.16.45.55 
default via 10.16.47.254 dev em1 

[root@dell-per715-01 ~]# arping 10.16.45.59 
arping: unknown iface eth0


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2011-09-26 04:58:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 RHEL Product and Program Management 2011-09-26 05:18:43 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 Suzanne Yeghiayan 2012-02-14 18:16:35 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 7 Jan Synacek 2012-07-16 08:10:05 EDT
Created attachment 598433 [details]
[Patch] Look for "eth" or "em" in /proc/self/net/dev
Comment 8 RHEL Product and Program Management 2012-09-07 01:11:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 9 Jan Synacek 2013-05-21 04:21:49 EDT
This bug hasn't been approved in the previous releases. I'm closing it as WONTFIX. If you or PM thinks otherwise, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.