Bug 741199 - BOOTPROTO missing in ifcfg-eth0 in minimal install
BOOTPROTO missing in ifcfg-eth0 in minimal install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
RejectedBlocker AcceptedNTH
:
Depends On:
Blocks: F16-accepted/F16FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-09-26 04:47 EDT by Kamil Páral
Modified: 2011-10-13 00:38 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-16.21-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-13 00:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2011-09-26 04:47:50 EDT
Description of problem:
Installed Fedora 16 Beta RC2 DVD i686 in minimal install. The system has 'network' service disabled by default, if you run:

# service network start

it will activate the devices for you. The problem is that ifcfg-eth0 doesn't contain BOOTPROTO line (it contains just DEVICE, HWADDR, ONBOOT and NM_CONTROLLED lines). Thus even if you start 'network' service by the previous command, you will have no network connectivity for eth0.

You must add BOOTPROTO="dhcp" into /etc/sysconfig/network-scripts/ifcfg-eth0 in order to have network working.

I believe it is:
1. unnecessary
2. bad default
3. not something all system administrators will be able to do (especially those coming from other distributions, they will know 'network' service but not know Fedora-specific configuration files and their options)

Version-Release number of selected component (if applicable):
anaconda 16.19

How reproducible:
always

Steps to Reproduce:
1. install minimal install from DVD
2. run 'service network start'
3. run 'ip a' to check that eth0 doesn't have IP address assigned
4. add BOOTPROTO="dhcp" into /etc/sysconfig/network-scripts/ifcfg-eth0
5. run 'service network restart'
6. run 'ip a' to check that eth0 now has IP address assigned
Comment 1 Kamil Páral 2011-09-26 04:49:09 EDT
Even though I haven't find exact release criteria, proposing as a final blocker or at least a nice-to-have, because it's essential functionality, it might cause problems for some administrators, and it should be easy to fix.
Comment 2 Tim Flink 2011-10-03 12:54:42 EDT
Discussed in the 2011-09-30 blocker bug review meeting. Rejected as a blocker bug for Fedora 16 final because it doesn't hit any of the release criteria.

There isn't quite enough information here to make a decision about NTH right now but it will be re-visited.

Questions:
 - Is the missing BOOTPROTO really the reason that network isn't starting?
 - Is the network not running by default on a minimal install by design?
 - Is the ifcfg script set as "NM_CONTROLLED=no"?
Comment 3 Radek Vykydal 2011-10-04 04:57:30 EDT
(In reply to comment #2)

> Questions:

>  - Is the missing BOOTPROTO really the reason that network isn't starting?
I believe so.

>  - Is the network not running by default on a minimal install by design?
No, but it is out of scope of this bug, please see bug #702261.

>  - Is the ifcfg script set as "NM_CONTROLLED=no"?
It is set to "yes", IIRC network service should not care in case of minimal install (NM is not part of minimal install), but I'll better check.

I'll investigate whether we can write default BOOTPROTO=dhcp in loader without breaking anything (this could also solve bug 705718).
Comment 4 Kamil Páral 2011-10-04 05:55:08 EDT
(In reply to comment #2)
> Questions:
>  - Is the missing BOOTPROTO really the reason that network isn't starting?

According to my testing it is the only reason why eth0 doesn't get IP address when I start network service.

>  - Is the ifcfg script set as "NM_CONTROLLED=no"?

It is set to "yes", but it seems to have no negative impact. I suppose it doesn't apply until you have NetworkManager installed.
Comment 5 Jirka Klimes 2011-10-04 09:29:18 EDT
(In reply to comment #4)
> (In reply to comment #2)
> > Questions:
> >  - Is the missing BOOTPROTO really the reason that network isn't starting?
> 
> According to my testing it is the only reason why eth0 doesn't get IP address
> when I start network service.
> 
Yeah, without BOOTPROTO set to "bootp" or "dhcp", init scripts assume manual IP addressing and try setting IP address(es) according to IPADDR (that is not present as well).

Excerpt from /etc/sysconfig/network-scripts/ifup-eth:
if [ "${BOOTPROTO}" = "bootp" -o "${BOOTPROTO}" = "dhcp" ]; then
    DYNCONFIG=true
fi

> >  - Is the ifcfg script set as "NM_CONTROLLED=no"?
> 
> It is set to "yes", but it seems to have no negative impact. I suppose it
> doesn't apply until you have NetworkManager installed.

NM_CONTROLLED is not taken into account when NM is not running.
Comment 6 Radek Vykydal 2011-10-05 07:14:25 EDT
(In reply to comment #3)

> 
> I'll investigate whether we can write default BOOTPROTO=dhcp in loader without
> breaking anything (this could also solve bug 705718).

proposed patch:
https://www.redhat.com/archives/anaconda-devel-list/2011-October/msg00019.html
Comment 7 Radek Vykydal 2011-10-06 06:56:43 EDT
This should be fixed in F16 post beta.
Comment 8 Adam Williamson 2011-10-07 15:13:17 EDT
Discussed at 2011-10-07 blocker review meeting. Accepted as NTH: this is clearly incorrect, has an obvious consequence on non-NM installs, and can't be fixed post-install.
Comment 9 Fedora Update System 2011-10-11 14:35:24 EDT
anaconda-16.21-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.21-1.fc16
Comment 10 Andre Robatino 2011-10-12 16:34:24 EDT
After doing both text-based and minimal GUI installs from 20111011_preTC1.x64.boot.iso (see http://lists.fedoraproject.org/pipermail/test/2011-October/103542.html ) the ifcfg-* file looks correct (has BOOTPROTO="dhcp" and ONBOOT="yes") but the network does not come up automatically at boot time. It comes up immediately if I use the dhclient command ("dhclient eth0", for example). Tim Flink confirmed this.
Comment 11 Adam Williamson 2011-10-12 18:15:15 EDT
From the original report:

"Installed Fedora 16 Beta RC2 DVD i686 in minimal install. The system has
'network' service disabled by default, if you run:

# service network start

it will activate the devices for you. The problem is that ifcfg-eth0 doesn't
contain BOOTPROTO line (it contains just DEVICE, HWADDR, ONBOOT and
NM_CONTROLLED lines). Thus even if you start 'network' service by the previous
command, you will have no network connectivity for eth0."

so the 'network' service being disabled by default still has to be 'fixed' to 'fix' the minimal install case. This bug was specifically for the lack of BOOTPROTO="dhcp" , not for the general problem.

To be sure of the fix you could confirm that a Beta install does not bring the adapter up even after 'systemctl start network.service' but a pre-TC1 install does.
Comment 12 Fedora Update System 2011-10-13 00:38:03 EDT
anaconda-16.21-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.