Bug 741205 - err: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: change from notrun to 0 failed: /usr/bin/rake db:create returned 1 instead of one of [0] in aeolus-configure
Summary: err: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Mo Morsi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On: 741162
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 09:23 UTC by Aziza Karol
Modified: 2011-11-08 17:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 19:48:34 UTC


Attachments (Terms of Use)

Description Aziza Karol 2011-09-26 09:23:55 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.yum install aeolus-all
2.aeolus-configure


Actual results:
root@dell-pe1950-03 noarch]# aeolus-configure
Launching aeolus configuration recipe...
notice: /Stage[main]/Apache/Exec[permit-http-networking]/returns: executed successfully
notice: /Stage[main]/Apache/Service[httpd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Ntp::Client/Service[ntpd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Conductor/Selinux::Mode[permissive]/Exec[set_selinux_permissive]/returns: executed successfully
notice: /Stage[main]/Aeolus::Deltacloud::Core/Service[deltacloud-core]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully
notice: /Stage[main]/Aeolus::Iwhd/Service[mongod]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Image-factory/Service[qpidd]/ensure: ensure changed 'stopped' to 'running'
notice: /File[/var/lib/iwhd]/ensure: created
notice: /Stage[main]/Aeolus::Iwhd/Service[iwhd]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:                                  Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0xec[create-bucket-aeolus]/returns: 
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: executed successfully
notice: /File[/var/lib/aeolus-conductor]/ensure: created
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: rake aborted!
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: Unable to activate rack-restful_submit-1.2.1, because rack-1.1.0 conflicts with rack (~> 1.3.0)
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: 
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: (See full trace by running task with --trace)
notice: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: Using gem require instead of bundler
err: /Stage[main]/Aeolus::Conductor/Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: change from notrun to 0 failed: /usr/bin/rake db:create returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/rails.pp:22
notice: /Stage[main]/Aeolus::Conductor/Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Conductor/Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Conductor/Service[aeolus-conductor]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Conductor/Service[aeolus-conductor]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Conductor/Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Conductor/Rails::Seed::Db[seed_aeolus_database]/Exec[seed_rails_database]: Skipping because of failed dependencies
notice: /File[/var/lib/aeolus-conductor/production.seed]: Dependency Exec[create_rails_database] has failures: true
warning: /File[/var/lib/aeolus-conductor/production.seed]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Image-factory/Service[imagefactory]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[create_site_admin_user]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Site_admin[admin]/Exec[grant_site_admin_privs]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Login[admin]/Web_request[admin-conductor-login]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Login[admin]/Web_request[admin-conductor-login]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-east-1]/Web_request[provider-ec2-us-east-1]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-east-1]/Web_request[provider-ec2-us-east-1]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp2]/Web_request[hwp-hwp2]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp2]/Web_request[hwp-hwp2]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-west-1]/Web_request[provider-ec2-us-west-1]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[ec2-us-west-1]/Web_request[provider-ec2-us-west-1]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp1]/Web_request[hwp-hwp1]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Hwp[hwp1]/Web_request[hwp-hwp1]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[mock]/Web_request[provider-mock]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider[mock]/Web_request[provider-mock]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider::Account[mockuser]/Web_request[provider-account-mockuser]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Provider::Account[mockuser]/Web_request[provider-account-mockuser]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Logout[admin]/Web_request[admin-conductor-logout]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Default/Aeolus::Conductor::Logout[admin]/Web_request[admin-conductor-logout]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Conductor/Service[conductor-dbomatic]: Dependency Exec[create_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Conductor/Service[conductor-dbomatic]: Skipping because of failed dependencies
notice: Finished catalog run in 8.47 seconds





Additional info:
[root@nec-em16 src]# rpm -qa | egrep 'aeolus|rubygem-rack-restful'
aeolus-conductor-0.4.0-0.20110921152740gitac47a38.fc15.noarch
rubygem-rack-restful_submit-doc-1.2.1-1.fc15.noarch
aeolus-configure-2.0.2-4.20110923140029gitff33f9b.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110921152740gitac47a38.fc15.noarch
aeolus-all-0.4.0-0.20110921152740gitac47a38.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110921152740gitac47a38.fc15.noarch
rubygem-rack-restful_submit-1.2.1-1.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch

Comment 1 wes hayutin 2011-09-26 18:30:40 UTC
clean up is also messed up..


[root@unused configure]# aeolus-cleanup -d -v
dnsdomainname: Name or service not known
info: Applying configuration version '1317061781'
notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Service[deltacloud-core]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Service[qpidd]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[iwhd]/ensure: ensure changed 'running' to 'stopped'
notice: /File[/var/lib/iwhd]/ensure: removed
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[mongod]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: rake aborted!
notice: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: Unable to activate rack-restful_submit-1.2.1, because rack-1.1.0 conflicts with rack (~> 1.3.0)
notice: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: 
notice: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: (See full trace by running task with --trace)
notice: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: Using gem require instead of bundler
err: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: change from notrun to 0 failed: /usr/bin/rake db:drop returned 1 instead of one of [0] at /usr/share/aeolus-configure/modules/aeolus/manifests/rails.pp:56
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]: Dependency Exec[drop_rails_database] has failures: true
warning: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[httpd]/ensure: ensure changed 'running' to 'stopped'

Comment 2 wes hayutin 2011-09-26 18:48:35 UTC
looks like this is caused by https://bugzilla.redhat.com/show_bug.cgi?id=741162

Comment 3 Mo Morsi 2011-09-26 19:48:34 UTC

*** This bug has been marked as a duplicate of bug 741162 ***


Note You need to log in before you can comment on or make changes to this bug.