Bug 74123 - cluadmin chews 99+% of CPU time
cluadmin chews 99+% of CPU time
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-16 11:15 EDT by Lon Hohberger
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-16 11:19:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2002-09-16 11:15:48 EDT
Description of Problem: In some cases, when the shell which spawned cluadmin is
terminated for one reason or another, cluadmin becomes stuck in a _tight_
read-write loop:

read(0, "", 1)                          = 0
write(1, "\7", 1)                       = -1 EIO (Input/output error)
read(0, "", 1)                          = 0
write(1, "\7", 1)                       = -1 EIO (Input/output error)
read(0, "", 1)                          = 0
write(1, "\7", 1)                       = -1 EIO (Input/output error)
read(0, "", 1)                          = 0
...

Version-Release number of selected component (if applicable): 1.0.11,
CVS/Development


How Reproducible: Sometimes


Steps to Reproduce:
1. Run cluadmin
2. Log in to a different terminal.
3. Kill the shell which spawned cluadmin.


Actual Results: Cluadmin enters read/write loop, consuming nearly all of the CPU.


Expected Results: Cluadmin cleanly exits.


Additional Information:  Personally, I have been unable to reproduce this
problem.  I have, however, found the cause of this and implemented code which is
now in testing.  This bugzilla is mainly for documentation purposes.
Comment 1 Lon Hohberger 2002-09-19 11:10:36 EDT
Fix in pool.

Note You need to log in before you can comment on or make changes to this bug.