Bug 741248 - GTK does not have a dependency on the fonts necessary to render widgets
Summary: GTK does not have a dependency on the fonts necessary to render widgets
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 11:45 UTC by Graham White
Modified: 2014-09-25 05:52 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 988032 (view as bug list)
Environment:
Last Closed: 2012-08-07 19:58:08 UTC


Attachments (Terms of Use)

Description Graham White 2011-09-26 11:45:58 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.21 Safari/535.2

The package for virt-manager in Fedora 15 x86_64 seems to be missing a dependency for the files provided by the package xorg-x11-fonts-Type1.noarch.

Reproducible: Always

Steps to Reproduce:
Here's what I did...

1. Network install Fedora 15 x86_64 using the "minimal" install option
2. Yum install the "Base", "Virtualisation" and "X Window System" groups
3. Connect to the system via SSH with X Forwarding
4. Run virt-manager
Actual Results:  
Without this package virt-manager does not display any fonts (squares are rendered where fonts should be).

Expected Results:  
I should be able to run virt-manager and have it display correctly.

Comment 1 Cole Robinson 2011-09-26 14:51:54 UTC
virt-manager shouldn't need to depend on this. Maybe the "X Window System" comps group or gtk should pull in xorg-x11-fonts-Type1

Reassigning to comps

Comment 2 Bill Nottingham 2011-09-26 14:55:02 UTC
If you want fonts, install the fonts group.

Comment 3 Graham White 2011-09-26 15:27:07 UTC
The package xorg-x11-fonts-Type1 required by virt-manager is not part of the Fonts group so that wouldn't help.

Comment 4 Daniel Berrangé 2011-09-26 15:32:17 UTC
> The package xorg-x11-fonts-Type1 required by virt-manager is not part of the
> Fonts group so that wouldn't help.

AFAIK, virt-manager does not require any particular font to be installed. Any requirement for particular fonts is imposed by GTK or the GTK theme, so it is those packages which should deal with dependencies.

Comment 5 Graham White 2011-09-27 06:43:26 UTC
Yes that's more than likely the case I should think.  To discover the package I've reported here I ran an strace against virt-manager.  I had been installing a few random font packages but none of them seemed to work.  Perhaps the GTK packages should source a minimal set of fonts, after all, getting the user to do that separately for a system that clearly requires some sort of text display functionality seems a little odd to me.  Is it worth opening a separate bug against the GTK packages?

Comment 6 Trey Dockendorf 2011-10-17 04:51:03 UTC
I've run into this on a minimal system with no X Windows installed.  I only access virt-manager via X11 forwarding, and have solved the problem by installing dejavu-lgc-sans-fonts.  That's the single package I've found to solve this problem.

Comment 7 Fedora End Of Life 2012-08-07 19:58:12 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.