Bug 741274 - Non-ascii chars in org description - error on org list
Summary: Non-ascii chars in org description - error on org list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-26 13:20 UTC by Garik Khachikyan
Modified: 2019-09-25 21:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:58:28 UTC


Attachments (Terms of Use)

Description Garik Khachikyan 2011-09-26 13:20:38 UTC
Description of problem:
trying: org update --name org1 --description "您好" goes ok (and UI show properly)
But display of org list fails:
---
error: 'ascii' codec can't encode characters in position 0-1: ordinal not in range(128) (more in the log file)
---
Please fix this issue: we need to be consistent on both: UI & API side (what shows ui, the same should do api there). TY.


Version-Release number of selected component (if applicable):
katello-cli-0.1.10-1.git.278.85760dc.el6.noarch
katello-0.1.83-1.git.48.02111ba.fc15.noarch

How reproducible:
always entering non-ascii chars

Steps to Reproduce:
1.see in descr.
2.
3.
  
Actual results:
Fails on listing the orgs when there is a one with special characters there.

Expected results:
No problem to display the non-ascii characters - be same as UI is.

Additional info:

Comment 2 Garik Khachikyan 2011-09-26 13:28:27 UTC
same issue when you have special chars in the name of the org. UI works, CLI - fails.

Seems there is a global issue here - so please confirm, if we would/ be / could fixing that for CLI?

Comment 3 Ivan Necas 2011-10-10 10:25:18 UTC
Fixed in commits 26653a2a3d157e879398aef276c69fd2c0dcdbad and bc4a8811c9b55d8dc194fdccb84a2c76209d7eaf.

This commits should fix it globally, but more testing for another parts of CLI is welcome.

Comment 4 Garik Khachikyan 2011-11-14 09:26:00 UTC
# VERIFIED

checked in both: description and name of org creation - works perfectly.

randomly checked the non-ascii chars in some other cli calls - so far are fine.

Packages the verification was made:
katello-0.1.101-1.git.30.d57dd1d.el6.x86_64
katello-cli-0.1.11-1.git.0.facb3bb.el6.noarch

Comment 7 Hayk Hovsepyan 2012-12-04 10:45:47 UTC
Automated in method: "com.redhat.qe.katello.tests.cli.OrgTests.test_updateOrg()"

Comment 8 Mike McCune 2013-08-16 17:57:58 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.