Bug 741282 - When going from multi mon to single monitor config, client still shows multiple monitors
Summary: When going from multi mon to single monitor config, client still shows multip...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 6.2
Assignee: Søren Sandmann Pedersen
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 747120
TreeView+ depends on / blocked
 
Reported: 2011-09-26 13:42 UTC by Hans de Goede
Modified: 2014-06-18 09:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:08:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1621 normal SHIPPED_LIVE xorg-x11-drv-qxl bug fix and enhancement update 2011-12-06 00:50:59 UTC

Description Hans de Goede 2011-09-26 13:42:14 UTC
Steps to Reproduce:
1. Create a RHEL-6.2 vm with multiple qxl devices
2. Connect with spicec
3. You get one window
4. Add an xorg.conf to use more then one monitor (tested with 2 and 4)
5. Restart Xorg
6. Now you've multiple spicec windows
7. Remove xorg.conf
8. Restart Xorg
9. You still have multiple spicec windows, but only 1 gets updates / is used
10. Disconnect, restart spice client, still multiple windows
  
Actual results:
More spicec windows then are being used by the guest

Expected results:
As much spicec windows as are being used by the guest

Additional info:
I think we need to do a destroy on the primary surfaces on X server shutdown to fix this.

Comment 4 Hans de Goede 2011-10-08 13:06:29 UTC
FWIW, I gave the fixed package a number of test runs and it works for me.

Comment 5 Lubos Kocman 2011-10-18 11:29:34 UTC
Verified on xorg-x11-drv-qxl-0.0.14-10.el6.

Comment 6 errata-xmlrpc 2011-12-06 15:08:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1621.html


Note You need to log in before you can comment on or make changes to this bug.