This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 74129 - upgrading postfix broken by failure to upgrade chroot
upgrading postfix broken by failure to upgrade chroot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: postfix (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-16 14:34 EDT by Chris Ricker
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-20 11:15:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-09-16 14:34:35 EDT
RHL 7.3 shipped with postfix chroot()ed to /var/spool/postfix, necessitating
inclusion of libraries and config files copied into that jail.

On upgrade from 7.3 to postfix-1.1.11-5, the chroot jail is not updated.  From
my postfix startup messages:

Sep 14 18:28:40 hanuman postfix/postfix-script: stopping the Postfix mail system
Sep 14 18:28:40 hanuman postfix/master[662]: terminating on signal 15
Sep 14 23:56:13 hanuman postfix/postfix-script: warning: /var/spool/postfix/etc/
services and /etc/services differ
Sep 14 23:56:14 hanuman postfix/postfix-script: warning: /var/spool/postfix/lib/
libnss_winbind.so and /lib/libnss_winbind.so differ
Sep 14 23:56:14 hanuman postfix/postfix-script: warning: /var/spool/postfix/lib/
libnss_wins.so and /lib/libnss_wins.so differ
Sep 14 23:56:14 hanuman postfix/postfix-script: warning: /var/spool/postfix/lib/
libdb-3.3.so and /lib/libdb-3.3.so differ
Sep 14 23:56:14 hanuman postfix/postfix-script: starting the Postfix mail system
Sep 14 23:56:14 hanuman postfix/master[731]: daemon started

In particular, failure to update the libraries caused weird hanging connections.
 After manually copying the newer files in place, everything works.
Comment 1 Chris Ricker 2003-05-20 11:15:44 EDT
This has since been fixed -- didn't see this going from 8.0 -> 9

Note You need to log in before you can comment on or make changes to this bug.