Bug 741335 - changes to allow auto-healing from rhsmcertd
changes to allow auto-healing from rhsmcertd
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-09-26 11:43 EDT by Jesus M. Rodriguez
Modified: 2011-12-06 12:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:24:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
actual approved changes (3.12 KB, patch)
2011-09-26 11:46 EDT, Jesus M. Rodriguez
no flags Details | Diff
verification (27.62 KB, text/plain)
2011-10-10 15:40 EDT, J.C. Molet
no flags Details

  None (edit)
Description Jesus M. Rodriguez 2011-09-26 11:43:22 EDT
Client needs changes for auto-healing
Comment 1 Jesus M. Rodriguez 2011-09-26 11:46:19 EDT
Created attachment 524931 [details]
actual approved changes
Comment 7 J.C. Molet 2011-10-10 15:40:00 EDT
Created attachment 527305 [details]
verification

rhsm now attempts to heal upon ever rhsmcertd restart, and whenever its heal_frequency is reached.

VERIFIED against: 
subscription-manager-gnome-0.96.13-1.git.5.2e86717.el6.x86_64
subscription-manager-0.96.13-1.git.5.2e86717.el6.x86_64
python-rhsm-0.96.13-1.git.0.a237980.el6.noarch
subscription-manager-firstboot-0.96.13-1.git.5.2e86717.el6.x86_64

The attached shows that a heal was automatically done after the daemon restarted.
Comment 8 errata-xmlrpc 2011-12-06 12:24:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.