Bug 741336 - Role target select list populated with wrong kind of entity
Summary: Role target select list populated with wrong kind of entity
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-26 15:43 UTC by Jeff Weiss
Modified: 2019-09-26 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:58:32 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-09-26 15:43:22 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.84-1.git.26.51fa1e1.fc14.noarch

How reproducible:
always

Steps to Reproduce:
1. Create a role myrole 
2. Add a permission to ACME_Corporation:  Provider, Access Provider, choose 1 provider.
3. In the breadcrumb in the right pane, click "Permissions" to go back up
4. Add another permission - Global, Users, Access users

Actual results:
WHen you click Next after selecting "Access Users", the "On" section is still displaying the list of Providers from the first permission we created.

Expected results:
Empty list, permission is always for all users, IIUC

Additional info:

Comment 1 Partha Aji 2012-01-24 00:38:00 UTC
Not able to reproduce this. Possibly the issue has been resolved. Fail if this occurs again.

Comment 3 Jeff Weiss 2012-02-09 21:32:00 UTC
Cannot reproduce in katello-0.1.229-1.git.0.f2ad9e2.el6.noarch

Verified.


Note You need to log in before you can comment on or make changes to this bug.