Bug 741337 - Client blocks indefinitely on virStream API
Summary: Client blocks indefinitely on virStream API
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Privoznik
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 691830
TreeView+ depends on / blocked
 
Reported: 2011-09-26 15:43 UTC by Michal Privoznik
Modified: 2011-12-06 11:34 UTC (History)
7 users (show)

Fixed In Version: libvirt-0.9.4-14.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:34:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Michal Privoznik 2011-09-26 15:43:30 UTC
Description of problem:
Client blocks indefinitely on any API involving virStream API, e.g. virStorageVolDownload, virDomainScreenshot. Although data is transfered, no termination of communication between daemon and client can be observed takes place.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-13.el6

How reproducible:
100%

Steps to Reproduce:
1. virsh vol-download /path/to/a/volume tmp.img
2.
3.
  
Actual results:
virsh blocks

Expected results:
virsh will not block and copy volume

Additional info:
This is a regression caused by 984840a2c292402926ad100aeea33f8859ff31a9 but we have fix already.

Comment 5 Nan Zhang 2011-09-29 09:50:27 UTC
Reproduce with -13:

# virsh -c qemu+ssh://10.66.4.233/system vol-download foo.img /var/lib/libvirt/images/foo1.img --pool default
root@10.66.4.233's password: 
error: cannot receive data from volume foo.img
error: End of file while reading data: : Input/output error

Killed


Verified with -14, it's already fixed. Move this to VERIFIED.

# virsh -c qemu+ssh://10.66.4.233/system vol-download foo.img /var/lib/libvirt/images/foo1.img --pool default
root@10.66.4.233's password:

Comment 6 errata-xmlrpc 2011-12-06 11:34:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.