Bug 741352 - defuct passwd process left over when using setup
Summary: defuct passwd process left over when using setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 16:22 UTC by Joey Boggs
Modified: 2016-04-26 15:15 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.9.git9048c81.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:28:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Joey Boggs 2011-09-26 16:22:35 UTC
after logging in as admin and using the setup there will be left over defunct passwd processes

Comment 2 Ying Cui 2011-09-27 10:05:46 UTC
Hi Joey,
   Could you prepare the detail test steps to verify this bug, we can not reproduce it with our test steps.

our test steps:
1. login as admin user.
2. F2 to shell.
3. run 'exit' to return to setup.
4. ssh admin@ip address.
5. F2 to shell
6. #top
7. #ps -ef|grep defunc

we can not reproduce this issue, there is no defunct passwd process.


Thanks
Ying

Comment 3 Joey Boggs 2011-09-27 12:19:22 UTC
those steps should be enough to reproduce it, Steve can you tell us if they were reproduced by doing anything else

Comment 4 Steve Grubb 2011-09-27 12:59:41 UTC
Actually, I get in another way.
1) login as admin
2) press F10
3) choose any log
4) Enter  ":!!/bin/sh" when the log is on the screen
5) this should drop you to a command prompt, if not try again and make sure !! is on the line. It seems to discard the first one.
6) ps -ef | grep passwd

Comment 5 Joey Boggs 2011-09-27 13:13:22 UTC
ok just retried it and the patch is still good

Comment 7 Guohua Ouyang 2011-10-09 05:38:21 UTC
Verified on 6.2-20111006 build:
1. Press F8 and choose any log, enter ":!!/bin/sh"  cannot drop to shell.
2. `ps -ef | grep passwd`, no defunct passwd process.

Comment 8 errata-xmlrpc 2011-12-06 19:28:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.