Bug 741353 - Start-up of mongod appears impossible under systemd
Summary: Start-up of mongod appears impossible under systemd
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mongodb
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Chris Lalancette
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-26 16:27 UTC by Alex Hudson (Fedora Address)
Modified: 2011-09-26 17:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 17:35:35 UTC


Attachments (Terms of Use)

Description Alex Hudson (Fedora Address) 2011-09-26 16:27:27 UTC
Description of problem:

I can't start mongodb :(

Version-Release number of selected component (if applicable):

mongodb-1.8.2-9.fc16.x86_64

How reproducible:

Always

Steps to Reproduce:
1. systemctl start mongodb.service
  
Actual results:

Fail (ed to issue method call: Unit mongodb.service failed to load: No such file or directory)

Expected results:

Win

Additional info:

# rpm -ql mongodb | grep -c service 
0

# yum install mongodb
Package mongodb-1.8.2-9.fc16.x86_64 already installed and latest version

Comment 1 Chris Lalancette 2011-09-26 17:35:35 UTC
That's because the service isn't called mongodb (it's called mongod), and you (probably) don't have the mongodb-server package installed.


[root@localhost ~]# rpm -qa | grep mongo
mongodb-server-1.8.2-9.fc16.x86_64
mongodb-1.8.2-9.fc16.x86_64
libmongodb-1.8.2-9.fc16.x86_64
[root@localhost ~]# rpm -ql mongodb-server | grep service
/lib/systemd/system/mongod.service
[root@localhost ~]# systemctl start mongod.service
[root@localhost ~]# systemctl status mongod.service
mongod.service - High-performance, schema-free document-oriented database
	  Loaded: loaded (/lib/systemd/system/mongod.service; disabled)
	  Active: active (running) since Mon, 26 Sep 2011 13:34:34 -0400; 9s ago
	 Process: 995 ExecStart=/usr/bin/mongod $OPTIONS run (code=exited, status=0/SUCCESS)
	Main PID: 998 (mongod)
	  CGroup: name=systemd:/system/mongod.service
		  └ 998 /usr/bin/mongod --quiet -f /etc/mongodb.conf run
[root@localhost ~]# ps -efwww | grep mongo
mongodb    998     1  0 13:34 ?        00:00:00 /usr/bin/mongod --quiet -f /etc/mongodb.conf run
root      1008   931  0 13:34 pts/0    00:00:00 grep --color=auto mongo
[root@localhost ~]# 

Of course, if you still are having problems after installing that, please feel free to re-open.


Note You need to log in before you can comment on or make changes to this bug.