Bug 741399 - Roles/Permissions: For Global permissions, ALL should be implied for "On"
Summary: Roles/Permissions: For Global permissions, ALL should be implied for "On"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-26 18:05 UTC by Corey Welton
Modified: 2019-09-26 13:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:58:39 UTC


Attachments (Terms of Use)

Description Corey Welton 2011-09-26 18:05:45 UTC
Description of problem:
When configuring a global permission, after selecting verbs, an empty listbox appears for tags.  This is unnecessary.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a new role, foofah_role
2. Navigate to role, Permissions > Global Permissions > Add Permission
3. Select Permission "Users" and verb of "Access Users"; hit Next

  
Actual results:
Empty tags box appears w/ "All" buton

Expected results:
ALL should be implied for Global permissions, no listbox is necessary nor should appear.

Additional info:

Comment 1 Eric Helms 2011-10-03 15:12:49 UTC
commit 76b63bae32394dce47d1c8219e75b71dbc7652f3

When creating a global permission the On selection box has been removed since tags to not apply to global permissions.

Comment 2 Corey Welton 2011-10-07 18:23:03 UTC
QA Verified.

Comment 5 Mike McCune 2013-08-16 18:07:41 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.