Bug 7414 - linuxconf-vpop3d chrashes
linuxconf-vpop3d chrashes
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-29 11:20 EST by niels
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-02 14:16:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description niels 1999-11-29 11:20:26 EST
set up a virtual email-domain with linuxconf. every now and then (say twice
a week) the vpop3d just stops saying:
inetd[426]: pop-3/tcp server failing (looping), service terminated.
Comment 1 jack 1999-11-30 11:50:59 EST
This is not a bug in vpop3d. This is a normal message from inetd. inetd
is the one starting vpop3d for every session. It tries to avoid a denyal of
service attack. It limits the number of connection to 40 per minutes. If you
get more, it is assuming that you are either under attack or that the vpop3d
service is failing so the client are retrying and retrying. So it disable
the service for 5 minutes.

40 connections per minutes is generally too low for many servers, especially
ISPs. In the file /etc/inetd.conf, locate the vpop3d line and change the nowait
word for nowait.100. Here 100 is just a number bigger than 40. I assume that if
you get this problem twice a week, you are just border line with 40 (the
default) so 100 will be plenty enough.

Note You need to log in before you can comment on or make changes to this bug.