Common Vulnerabilities and Exposures assigned an identifier CVE-2011-3757 to
the following vulnerability:
Moodle 2.0.1 allows remote attackers to obtain sensitive information
via a direct request to a .php file, which reveals the installation
path in an error message, as demonstrated by
webservice/xmlrpc/locallib.php and certain other files.
Created moodle tracking bugs for this issue
Affects: fedora-all [bug 741409]
Affects: epel-all [bug 741410]
All our branches that have moodle >= 2.0.x are 2.0.3 or greater, does this affect those, or the 1.9.x or 1.8.x branches?
AFAIK, this probably affects 2.0.3. I do not know about 1.9.x or 1.8.x but I would assume they are affected as well. I have not had time to dig into the code directly to find out for sure.
Fixed as of 10/21/2011.