Bug 741416 - Organization sorting not uniform between main view and Roles
Summary: Organization sorting not uniform between main view and Roles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-26 18:25 UTC by Corey Welton
Modified: 2013-08-16 18:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:58:42 UTC


Attachments (Terms of Use)
screenshot showing the roles create view still incorrect. (22.03 KB, image/png)
2011-10-25 03:56 UTC, Corey Welton
no flags Details

Description Corey Welton 2011-09-26 18:25:32 UTC
Description of problem:
Viewing a list of orgs in the main view displays them in one manner.  Viewing same list of orgs when creating a new role lists them in a different manner.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Create three new Orgs, "aaa", "bbb", "ccc"
2.  Navigate away from the orgs view to dashboard, and back to Orgs, in order to sort them (different bug)
3.  View sorting, with ACME_Corporation first, followed by your newly created orgs
4. Administration > Roles > New role "piffle" > Save
5. Roles view > "piffle" > Permissions
6. View sorting of Orgs in the role permissions view

Actual results:
aaa
ACME_Corporation
bbb
ccc

Expected results:
Probably should assure we're sorting Upper/Lower alphanumeric.  Or at very least, assure org view is uniform across UI

Additional info:

Comment 1 Brad Buckingham 2011-10-14 14:15:17 UTC
commit - ef6154de9e526ca8b4eebf9df3ff7e9b0671c4a9

Updated the sort order on the Organizations -> List to be consistent with the order of organizations from the sort page.

Using the example above, the order would be
aaa, ACME_Corporation, bbb, ccc

Comment 2 Corey Welton 2011-10-25 03:55:15 UTC
bouncing this back to dev for consideration.  note the forthcoming screenshot, in the roles creation view, we're still seeing the sorting as different than it is shown in the main Orgs view.

Comment 3 Corey Welton 2011-10-25 03:56:27 UTC
Created attachment 529995 [details]
screenshot showing the roles create view still incorrect.

Comment 4 Corey Welton 2011-12-14 16:35:58 UTC
This seems to be fixed now, verifying.

Comment 7 Mike McCune 2013-08-16 18:18:08 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.