Bug 741446 - Can't log in after Lock screen
Can't log in after Lock screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker F17-accepted/F17FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-09-26 16:27 EDT by Petr Schindler
Modified: 2012-05-21 15:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 15:09:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2011-09-26 16:27:10 EDT
Description of problem:
When testing https://fedoraproject.org/wiki/QA:Testcase_desktop_login I tried to lock screen, but I couldn't log in back again. I had to choose "Switch User" and log in from gdm. My keyboard layout is Czech. Password is written with this layout.

Version-Release number of selected component (if applicable):
gnome-screensaver 3.1.91

How reproducible:
Lock screen when loged in. Try to write password (it's written with czech keyboard layout). 

  
Actual results:
I can't log in back to desktop.

Expected results:
Unlock screen and see desktop.
Comment 1 Petr Schindler 2011-09-27 09:45:25 EDT
I made some further testing and I've found out that the keyboard layout is not switching when unlocking screen. It doesn't matter if it shows 'cz' or 'en' the english layout is still active (and password is written with it). That means that when someone has password with 'ยง' char in it, he can't unlock screen.

Additional information to How reproducible: it happens everytime I try it.
Comment 2 Adam Williamson 2011-09-27 15:54:02 EDT
Having trouble reproducing this in fallback mode. I did a default install from Beta RC3 DVD into a VM with French keyboard layout, and verified that works throughout the process of install, boot, add user, log in with that user, lock and unlock screen (using username and password 'azerty' as a test). Then I added en-US keyboard layout via GNOME control center (not system-config-keyboard) and tried playing with that. The 'unlock' dialog, at least in fallback mode, actually has an indicator of the current keyboard layout next to it, and this seems to be 'correct' in all my tests - if I locked with keyboard layout set to fr, the unlock dialog claims the layout is fr and this is in fact the case, if I lock with keyboard layout set to en, the dialog claims the layout is en and it indeed is.

Are you in Shell or fallback mode? Is there a layout indicator on the lock dialog? Did you configure layouts with GNOME control center or system-config-keyboard?
Comment 3 Petr Schindler 2011-09-27 19:03:18 EDT
I'm installing from LiveCD. I choose Czech keyboard layout as default, and it really works in whole installation. I add one user 'franta' with password 'za1-y23' (every character is on different place on Czech layout then on en). Czech layout is used as default when I log in first time. English layout is already given as option (I don't have to add it). I have cz layout choosed when I'm locking screen. The 'unlock' dialog have indicator of current layout (it's next to password field). It shows czech layout, but when I try to write password it's denied. But when I write password as if I have English layout it's accepted (but indicator still shows cz layout). When I change layout to English it works as expected (I write password with en layout).

I tried to add new layout (English dvorak). I discovered that Czech layout isn't default (it's not on top of list of layouts in GNOME control center). It's a bit strange, because I chose it as default in installation. I put Czech layout to the top of the list and then I tried again to lock screen. When I tried again to unlock it takes password written on czech layout (again no matter if indicator shows 'en' or 'cz'). I repeated it with English (dvorak) layout as default (on top of list) and it took only English (dvorak) layout when I was writting (and again, I couldn't change it by indicator.

So, I think, that problem is, that gnome-screensaver takes only default keyboard and you can't change it in password dialog (only change is label of layout, but layout itself stays ).
Comment 4 Petr Schindler 2011-09-30 07:11:24 EDT
I tried this in Fedore 15 and this bug is here too. So people who have password with characters which aren't on default keyboard (the one on top of the list of layouts in GNOME control center) can't unlock screen.
Comment 5 Adam Williamson 2011-09-30 16:14:39 EDT
Discussed at 2011-09-30 NTH review meeting. Accepted as at least NTH as this is clearly a significant issue that we would like to have fixed at release time.
Comment 6 Petr Schindler 2012-05-16 09:44:12 EDT
It is still broken. I'd like to propose it as blocker (because of bug 816554), but as it is too late I propose it only as NTH. I hope, that someone will look at it (in finite time).
Comment 7 Petr Schindler 2012-05-18 02:54:14 EDT
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=676293
Comment 8 Adam Williamson 2012-05-18 15:23:43 EDT
halfline says this is https://bugzilla.gnome.org/show_bug.cgi?id=675167 , which has a fix now.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Tim Flink 2012-05-18 18:00:59 EDT
Proposing as a blocker for Fedora 17 final because this is rather nasty and affects many users with non-us keyboards. Per the Fedora 17 final release criteria [1] :

There may be times where a requirement is unmet only in a particular configuration, such as with some keyboard layouts but not others, or if a particular character is used in a username, password or passphrase. In such cases, the release team should use their judgement and refer to precedent to determine whether or not the issue should be considered to block the release. They should consider the number of users likely to be affected by the issue, the severity of the case when the issue is encountered, and the ease or otherwise with which the issue can be avoided by both informed and uninformed users.

[1] http://fedoraproject.org/wiki/Fedora_17_Final_Release_Criteria
Comment 10 Fedora Update System 2012-05-18 21:42:29 EDT
gtk3-3.4.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gtk3-3.4.3-2.fc17
Comment 11 Petr Schindler 2012-05-21 03:38:10 EDT
gtk3-3.4.3-2.fc17 fixes this bug for me. Now I can use my ugly czech passwords, this is sooo cool. Thanks for update.
Comment 12 Adam Williamson 2012-05-21 14:57:37 EDT
I also confirmed the fix with a custom live spin. Setting VERIFIED. all systems go for RC3!
Comment 13 Fedora Update System 2012-05-21 15:09:28 EDT
gtk3-3.4.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.