Bug 74147 - Crashes on startup - PyXML dependancy problems
Crashes on startup - PyXML dependancy problems
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-printer (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-16 19:00 EDT by James Turner
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-15 10:06:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Turner 2002-09-16 19:00:15 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
(actually this relates to the redhat-config-printer-gui package, which isn't 
listed, but that's another story). 
 
Crashes on startup with an error pertaining to PyXML 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Install redhat-config-printer-gui 
2. Remove PyXML 
3. Try to run redhat-config-printer-gui 
	 
 
Actual Results:  It crashed with an error relating to the missing PyXML 
component. 
 
Expected Results:  It allows you to configure printers. 
 
Additional info: 
 
redhat-config-printer-gui depends on PyXML, but this information is not 
contained in its RPM file. There may be other missing dependancies too, though 
I have not currently investigated this further. 
 
The program was installed using the rpm command along with all explicitly 
defined dependancies on a partially upgraded Red Hat 7.3. The problem may not 
manifest itself on a fresh install of Null or if using the graphical install 
or package management tools. (not checked by me)
Comment 1 Tim Waugh 2002-09-17 03:32:07 EDT
PyXML _is_ required by redhat-config-printer-gui, and the RPM says so: 
 
$ rpm -qp --requires redhat-config-printer-0.4.21-1.i386.rpm | grep PyXML 
PyXML 
$ rpm -qp --requires redhat-config-printer-gui-0.4.21-1.i386.rpm | \ 
grep printer 
redhat-config-printer = 0.4.21-1 
 
So: 
redhat-config-printer-gui -> redhat-config-printer -> PyXML 
 
(Also, there is no redhat-config-printer-gui component, since that is not a 
SRPM package; bugs are filed against source packages not binary packages.)
Comment 2 James Turner 2002-09-23 05:05:12 EDT
Ah, the problem is not that the dependancy is completely missing but that there is no 
version number specified. You can still install the package if PyXML is installed but is 
the version from Red Hat 7.3, however the program crashes on startup. It starts working if 
you upgrade PyXML to the version from Null. 
 
"Steps to reproduce" in the original bug report were wrong.
Comment 3 Tim Waugh 2002-09-23 12:27:50 EDT
Ah, okay.  Thanks.
Comment 4 Tim Waugh 2002-10-16 08:37:07 EDT
Fixed in redhat-config-printer-0.6.12-1.

Note You need to log in before you can comment on or make changes to this bug.